Closed Bug 812227 Opened 8 years ago Closed 6 years ago

Bump minimum SDK version to 17

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect)

All
Android
defect
Not set
normal

Tracking

(firefox17-)

RESOLVED DUPLICATE of bug 1024238
Tracking Status
firefox17 - ---

People

(Reporter: kats, Unassigned)

References

Details

Not 100% this is needed but it will take time to do so filing it now. To fix bug 811763 we will probably need to use the android.os.UserManager API which is only in SDK >= 17, so we need to get this deployed everywhere as soon as we can.
Does this require a new SDK to be deployed, or is this just a code change?
AFAIK we'd have to update the SDKs deployed on the buildbots, and then after that's done push a code change to the mozconfigs to use android-17 instead of android-16.
Also note that we should be able to fix bug 811763 with reflection so this is no longer as urgent. Still good to have though :)
This is needed for stumbling service in Fennec to get cell signal strengths.

These are level 17 APIs:
CellSignalStrengthCdma
CellSignalStrengthGsm
CellSignalStrengthLte
Blocks: 1024708
Just found another
CellSignalStrengthWcdma is level 18

I'll investigate the importance of this one. If there is a delay bumping up to sdk 18, it will be useful to know how problematic this might be.
We already build with SDK 17: Bug 1024238 would mean that builds die if we aren't!

Min is still 8, will be 9 after Bug 1017244.

So I think this bug is "Bump targetSdkVersion to 18 or 19", right?
Component: General → Build Config & IDE Support
Or, rather, deploy and use SDK 19 on builders, then change 17 to 18 in Bug 1024238.
Sorry ignore Comment #4

Comment #5 is my problem, and to correct that, any of the Cell*Wcdma APIs are SDK 18.

Not actually a blocker, but very nice to have. I have refactored Fennec's stumbler not to require this. The API I need is used for neighbouring WCDMA cell scans -it is worth noting that not all phones support neighbouring cell scans. 
The connected cell query uses a different API, and we do get WCDMA info for this.
No longer blocks: 1024708
Blocks: 1030265
I had hopped on this bug incorrectly, the correct bug is this one: https://bugzilla.mozilla.org/show_bug.cgi?id=1030265
No longer blocks: 1030265
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1024238
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.