[Vertical] Marketplace app downloads show the default icon

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: kgrandon, Assigned: lightsofapollo)

Tracking

({regression, smoketest})

unspecified
2.0 S4 (20june)
x86
Mac OS X
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Probably a regression of the flurry of icon landings over the last day. The icon appears after a restart/relaunch so it's not terrible, but let's fix it.

Updated

4 years ago
Keywords: regression
True, although I don't think the content team would like it if the app installs without the icon. From my perspective, this is a blocker for content.
blocking-b2g: --- → 2.0?

Updated

4 years ago
Whiteboard: [systemsfe]
(Assignee)

Comment 2

4 years ago
So this is not _all_ marketplace apps but there is some condition where we cannot get an icon during install time and it causes problems =/ I tried this with Facebook and the Weather app and it works fine but the X-Type app (from the Staging Marketplace) does not work. Debugging.
(Assignee)

Comment 3

4 years ago
Created attachment 8439270 [details]
https://github.com/mozilla-b2g/gaia/pull/20450/files

Nope this is just a terrible typo that only happens while packaged apps are pending installation should be a blocker as this is at least a regression.
Attachment #8439270 - Flags: review?(kgrandon)
(Reporter)

Comment 4

4 years ago
Comment on attachment 8439270 [details]
https://github.com/mozilla-b2g/gaia/pull/20450/files

Looks good, and tests seem to be passing, so let's land it. Thanks!
Attachment #8439270 - Flags: review?(kgrandon) → review+
(Reporter)

Comment 5

4 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/f7bdf9572e1ce29acc5823ae5673b2c63fea1cdd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

4 years ago
Comment on attachment 8439270 [details]
https://github.com/mozilla-b2g/gaia/pull/20450/files

This is required for the vertical homescreen. We've done our best effort at testing and believe the tree will remain green with uplift.
Attachment #8439270 - Flags: approval-gaia-v2.0?(bbajaj)

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
Attachment #8439270 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+

Updated

4 years ago
Duplicate of this bug: 1024656

Updated

4 years ago
Keywords: smoketest
Verified on master. Edge case found. See bug 1024745 for details.
Status: RESOLVED → VERIFIED
v2.0: https://github.com/mozilla-b2g/gaia/commit/cacb46b03f7d2774dbdb2600f93ee5b9ce3fd7b0
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Verified Fixed on the latest Flame 2.1 and 2.0 builds.
Marketplace apps show correct icon on the Homescreen after downloading, even after stopping and restarting the download.

Environmental Variables:
Device: Flame 2.0
BuildID: 20141021000201
Gaia: 63b56a7a7453726b9e12ad1afe02c68c83c5aeca
Gecko: 40584eecdc75
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20141021001201
Gaia: e458f5804c0851eb4e93c9eb143fe044988cecda
Gecko: ee86921a986f
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.