Closed Bug 1024391 Opened 6 years ago Closed 5 years ago

Page is displayed blank after choosing the "Show" popup option

Categories

(Firefox for Android :: General, defect, major)

32 Branch
ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox30 --- unaffected
firefox31 --- wontfix
firefox32 --- verified
firefox33 --- verified
fennec 31+ ---

People

(Reporter: TeoVermesan, Assigned: billm)

References

Details

Attachments

(2 files)

Device: Alcatel One Touch
OS: Android 4.1

Steps to reproduce:
1. Go to http://www.popuptest.com/popuptest1.html 
2. Choose "Show" from the doorhanger notification

Expected results
- The doorhanger notification is dismissed and the popups are opened in new tabs.

Actual results:
- The page is blank.
- Closing the tab, the popups will be opened in new tabs.
Flags: needinfo?(teodora.vermesan)
Regression window wanted:
mozilla-central:

Good build: 21-03-2014
Bad build: 22-03-2014

pushlog:http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c148f0b0c8b4&tochange=72c2f9ebf4bc

Is Bug 933462 the cause?
Flags: needinfo?(teodora.vermesan)
Maybe the related toolkit code. I've CC'ed Bill to this bug.
tracking-fennec: --- → ?
Flags: needinfo?(wmccloskey)
Assignee: nobody → wmccloskey
tracking-fennec: ? → 31+
Blocks: 933462
Flags: needinfo?(wmccloskey)
Attached patch fix-popupsSplinter Review
I guess it was stupid of me to fix the URI.spec thing at the last minute since I forgot to update the Android and Metro code. Anyway, it's probably easiest just to make the URI actually be a URI.

Also, I found another bug in the original patch where we were calling updateBlockedPopups with the wrong parameters. I think this could cause us to lose popup blocking info when switching between tabs.

I'll back out bug 933462 on aurora. Sylvestre wants me to leave it on beta to minimize risk.
Attachment #8454009 - Flags: review?(felipc)
Attached patch 201057.diffSplinter Review
Approval Request Comment
[Feature/regressing bug #]: bug 933462
[User impact if declined]: Popup blocker broken on android.
[Describe test coverage new/current, TBPL]: we have popup blocker tests on desktop
[Risks and why]: If the backout passes tests, there should be very little risk.
[String/UUID change made/needed]: None
Attachment #8454012 - Flags: approval-mozilla-aurora?
Sorry, the previous comment was a patch to back out bug 933462.
Comment on attachment 8454012 [details] [diff] [review]
201057.diff

Backout approved.
Attachment #8454012 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Spoke with Bill about this. We're going to ship with this issue in 31, backout for 32 and let the new fix ride the 33 train.
Tested with:
Device: LG Nexus 4
OS: Android 4.4.2
The doorhanger notification is dismissed and the popups are opened in new tabs, so:
Verified fixed on:
Build: Firefox for Android 32.0a2 (2014-07-14)
Can we get a fix for 33 landed before merge?
Duplicate of this bug: 1039065
The bad thing about this bug going to release in Fx31 is that after the blank page is shown, the browser is unresponsive until you switch tabs, if you happen to figure that out. Bad experience.
Attachment #8454009 - Flags: review?(felipc) → review+
Severity: normal → major
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/37184d8682db
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Tested with:
Device: Samsung Galaxy Nexus
OS: Android 4.2.1
The doorhanger notification is dismissed and the popups are opened in new tabs, so:
Verified fixed on:
Build: Firefox for Android 33.0a2 (2014-07-24)
Status: RESOLVED → VERIFIED
Blocks: 1045826
Depends on: 1050130
No longer blocks: 1045826
Depends on: 1045826
No longer depends on: 1050130
Depends on: 1054826
Blocks: 1054840
You need to log in before you can comment on or make changes to this bug.