Closed Bug 1024397 Opened 6 years ago Closed 6 years ago

[Vertical] Activity: When a value selector is shown, press home button won't blur it

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: amirn, Assigned: aus)

References

Details

(Whiteboard: [systemsfe][p=3])

Attachments

(3 files)

see :alive comment here https://bugzilla.mozilla.org/show_bug.cgi?id=1021270#c19

STR:
1. long tap homescreen and choose `add collection`
2. wait for the suggestions list to load
3. tap the homebutton

expected:
the activity is closed, list is hidden, back to homescreen

observed:
list is not hidden
Kevin, IMO this one is a blocker.
A video would help clarify the bug here.
Keywords: qawanted
Attached file video of the bug
Is it a regression of that bug, or is it because we made the home button go to activities first? I wonder if we can just listen for hashchange and close ourself.
QA Wanted request was satisfied by reporter
Keywords: qawanted
(In reply to Kevin Grandon :kgrandon from comment #4)
> Is it a regression of that bug, or is it because we made the home button go
> to activities first? I wonder if we can just listen for hashchange and close
> ourself.

Maybe not. The problem is the value selector is first seen on an activity called by homescreen.
Home button will kill the activity but it seems the focus doesn't change to trigger the value selector to disappear.
Aus - if you get some time today and want to take a look at this one, it could be useful. Thanks!
Flags: needinfo?(aus)
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Pretty sure this is a big part of the problem:

E/GeckoConsole( 1507): [JavaScript Error: "NS_NOINTERFACE: " {file: "jar:file:///system/b2g/omni.ja!/components/ActivityWrapper.js" line: 73}]

when hitting the home button. 

Looks like the context for the activity is a little messed up. I'll keep you guys posted.
Assignee: nobody → aus
Status: NEW → ASSIGNED
Flags: needinfo?(aus)
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S4 (20june)
Blocks: 1015336
No longer blocks: vertical-homescreen
Alive, if this is the correct approach to fix this bug I will add tests to the pull request and flag for review.
Attachment #8441296 - Flags: feedback?(alive)
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8441296 [details] [review]
Pull Request - Hide value selector on 'activityclosing'

WFM
Attachment #8441296 - Flags: feedback?(alive) → feedback+
Comment on attachment 8441296 [details] [review]
Pull Request - Hide value selector on 'activityclosing'

Added some tests for this (and the other times we hide based on events).
Attachment #8441296 - Flags: review?(alive)
Comment on attachment 8441296 [details] [review]
Pull Request - Hide value selector on 'activityclosing'

r=me thanks.
Attachment #8441296 - Flags: review?(alive) → review+
Commit (master): https://github.com/mozilla-b2g/gaia/commit/5a53248d2404b6aa292c5d425f62c222e5cc1fd2

Commit (2.0): https://github.com/mozilla-b2g/gaia/commit/83844c7679b3b9f6e7f1116c1eeec2d1e7a64eec

Fixed!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [systemsfe] → [systemsfe][p=3]
Status: RESOLVED → VERIFIED
Attached video VIDEO0067_Compress.MP4
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141127000203
Version         32.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        5372b675e018b6aac97d95ff5db8d4bd16addb9b
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/f34377ae402b
Build-ID        20141127001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.