[tracking] Remove productization files for Metro

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: flod, Assigned: flod)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Assignee

Description

5 years ago
Thanks to bug 1018257, Metro strings are currently reported as obsolete on l10n-central and mozilla-aurora

We should use this bug to track the removal of productization files across locales, and eventually also localization files.

Localization files are stored in /browser/metro

p12n files include:
* /browser/metro/region.properties
* /browser/searchplugins/metrolist.txt (list of Metro searchplugins)
* /browser/searchplugins/*metrofx.xml (Metro version of search plugins)
Assignee

Comment 1

5 years ago
There's still an open issue: if l10n removed metrolist.txt, file will be reported as missing.

We either patch filter.py to ignore that file, or wait for en-US to remove it.
I'd suggest to add it to filter.py
Assignee

Updated

5 years ago
Depends on: 1024975
Assignee

Comment 3

5 years ago
Italian

Localization files removed on l10n-central
http://hg.mozilla.org/l10n-central/it/rev/54acf3d627ad

Searchplugins removed in 
http://hg.mozilla.org/l10n-central/it/rev/8fa362d3c887

Comment 13

5 years ago
Lithuanian (lt):

p12n and l10n files removed in http://hg.mozilla.org/l10n-central/lt/rev/a84c698c38b6
Assignee

Comment 14

5 years ago
Started cleaning up locales working on Pootle or not really active locales.

Only aurora changeset is reported, all locales can be merged clean into l10n-central.

http://hg.mozilla.org/releases/l10n/mozilla-aurora/ach/rev/3f4af7c1c4e2
http://hg.mozilla.org/releases/l10n/mozilla-aurora/af/rev/5da9ac1a7cf7
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ak/rev/a5131bc2836a
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ar/rev/357412bd4e24
http://hg.mozilla.org/releases/l10n/mozilla-aurora/as/rev/7b8c1caa38c1
http://hg.mozilla.org/releases/l10n/mozilla-aurora/bn-BD/rev/4823b0c6e100
http://hg.mozilla.org/releases/l10n/mozilla-aurora/bn-IN/rev/8e17f50ce6b8
http://hg.mozilla.org/releases/l10n/mozilla-aurora/cy/rev/e5a96b4aa66b
http://hg.mozilla.org/releases/l10n/mozilla-aurora/dsb/rev/48385d1cc390
http://hg.mozilla.org/releases/l10n/mozilla-aurora/en-ZA/rev/0e64d425ba5b
http://hg.mozilla.org/releases/l10n/mozilla-aurora/es-MX/rev/d16e51112838
http://hg.mozilla.org/releases/l10n/mozilla-aurora/fa/rev/0a4276e1822b
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ff/rev/fa6411e31971
http://hg.mozilla.org/releases/l10n/mozilla-aurora/gd/rev/2b055e0b5d12
http://hg.mozilla.org/releases/l10n/mozilla-aurora/hi-IN/rev/4df000bf833c
http://hg.mozilla.org/releases/l10n/mozilla-aurora/hr/rev/1da59a069d63
http://hg.mozilla.org/releases/l10n/mozilla-aurora/hsb/rev/f777ee24064e
http://hg.mozilla.org/releases/l10n/mozilla-aurora/hy-AM/rev/0642556ecc4d
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ka/rev/58e065a59fd3
http://hg.mozilla.org/releases/l10n/mozilla-aurora/kk/rev/7092d80e22f0
http://hg.mozilla.org/releases/l10n/mozilla-aurora/km/rev/118d0013f043
http://hg.mozilla.org/releases/l10n/mozilla-aurora/kn/rev/e8331f2e4270
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ku/rev/cdba00c72628
http://hg.mozilla.org/releases/l10n/mozilla-aurora/is/rev/044cca2cb499
http://hg.mozilla.org/releases/l10n/mozilla-aurora/lg/rev/b9b667dabe65
http://hg.mozilla.org/releases/l10n/mozilla-aurora/mai/rev/c0675630c7bd
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ml/rev/08b95af7da1a
http://hg.mozilla.org/releases/l10n/mozilla-aurora/mn/rev/4e8609d8b539
http://hg.mozilla.org/releases/l10n/mozilla-aurora/mr/rev/5569192117d5
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ms/rev/9637fcdd3d8c
http://hg.mozilla.org/releases/l10n/mozilla-aurora/my/rev/d2120e2fde1e
http://hg.mozilla.org/releases/l10n/mozilla-aurora/nso/rev/14d518265ed0
http://hg.mozilla.org/releases/l10n/mozilla-aurora/oc/rev/c79b124181c3
http://hg.mozilla.org/releases/l10n/mozilla-aurora/or/rev/e6d2d267c555
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ro/rev/f8f29367e6ee
http://hg.mozilla.org/releases/l10n/mozilla-aurora/rw/rev/406abe765124
http://hg.mozilla.org/releases/l10n/mozilla-aurora/sah/rev/531c3ab41273
http://hg.mozilla.org/releases/l10n/mozilla-aurora/si/rev/9670c5819471
http://hg.mozilla.org/releases/l10n/mozilla-aurora/son/rev/6729de797f74
http://hg.mozilla.org/releases/l10n/mozilla-aurora/sw/rev/353d0622535a
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ta/rev/ec008f1235c2
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ta-LK/rev/606162508265
http://hg.mozilla.org/releases/l10n/mozilla-aurora/te/rev/967784a7a25c
http://hg.mozilla.org/releases/l10n/mozilla-aurora/th/rev/9a617cfc231a
http://hg.mozilla.org/releases/l10n/mozilla-aurora/tr/rev/22c81523838e
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ur/rev/556d4790eb08
http://hg.mozilla.org/releases/l10n/mozilla-aurora/vi/rev/2b7cf70f9254
http://hg.mozilla.org/releases/l10n/mozilla-aurora/wo/rev/c66f9d943e72
http://hg.mozilla.org/releases/l10n/mozilla-aurora/xh/rev/4921e38aec44
http://hg.mozilla.org/releases/l10n/mozilla-aurora/zu/rev/bbe1294e81f4
Assignee

Comment 16

5 years ago
One more changeset
http://hg.mozilla.org/releases/l10n/mozilla-aurora/bs/rev/bec628a8a5b7

List of locales still having metro p12n files: an, ast, be, bg, cs, el, en-GB, eo, es-AR, es-CL, et, fi, fy-NL, gl, gu-IN, he, hu, ja, ja-JP-mac, lij, lt, lv, mk, nb-NO, nn-NO, pa-IN, pl, pt-BR, pt-PT, rm, sq, sv-SE, tn, uk, zh-CN

Comment 17

5 years ago
Bulgarian [bg]:

no l10n files to remove

p12n (only browser/searchplugins/metrolist.txt was present):
https://hg.mozilla.org/releases/l10n/mozilla-aurora/bg/rev/14c1a969ce22
Assignee

Comment 22

5 years ago
With this batch is should be completed

ast: http://hg.mozilla.org/releases/l10n/mozilla-aurora/ast/rev/fae86394defa
be: http://hg.mozilla.org/releases/l10n/mozilla-aurora/be/rev/897456f89538
el: http://hg.mozilla.org/releases/l10n/mozilla-aurora/el/rev/b6dc7b4bae1e
eo: http://hg.mozilla.org/releases/l10n/mozilla-aurora/eo/rev/77a4d902ef27
es-AR: http://hg.mozilla.org/releases/l10n/mozilla-aurora/es-AR/rev/03eaa2ac0904
et: http://hg.mozilla.org/releases/l10n/mozilla-aurora/et/rev/f8a0cb9e9f7e
fy-NL: http://hg.mozilla.org/releases/l10n/mozilla-aurora/fy-NL/rev/272e12c2027d
gl: http://hg.mozilla.org/releases/l10n/mozilla-aurora/gl/rev/ab4555c4082d
hu: http://hg.mozilla.org/releases/l10n/mozilla-aurora/hu/rev/a287c580c9c0
ja: http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/rev/6ce31c3a1c68
ja-JP-mac: http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja-JP-mac/rev/16bfe6c327d0
lij: http://hg.mozilla.org/releases/l10n/mozilla-aurora/lij/rev/f8bedc1334cd
mk: http://hg.mozilla.org/releases/l10n/mozilla-aurora/mk/rev/96cdc763481e
nb-NO: http://hg.mozilla.org/releases/l10n/mozilla-aurora/nb-NO/rev/7134465e9031
nn-NO: http://hg.mozilla.org/releases/l10n/mozilla-aurora/nn-NO/rev/2caf2bf5d109
pt-PT: http://hg.mozilla.org/releases/l10n/mozilla-aurora/pt-PT/rev/e9141c64260d
rm: http://hg.mozilla.org/releases/l10n/mozilla-aurora/rm/rev/113d1b87ba78
sq: http://hg.mozilla.org/releases/l10n/mozilla-aurora/sq/rev/a2bcdbc2ce0a
sv-SE: http://hg.mozilla.org/releases/l10n/mozilla-aurora/sv-SE/rev/3e680c1123d2
tn: http://hg.mozilla.org/releases/l10n/mozilla-aurora/tn/rev/eb59e19b8044
uk: http://hg.mozilla.org/releases/l10n/mozilla-aurora/uk/rev/aea134263156
zh-CN: http://hg.mozilla.org/releases/l10n/mozilla-aurora/zh-CN/rev/8e1c23afb6e1

Keeping open until next merge day to check if there are regressions.
Assignee

Comment 23

5 years ago
Closing, since we don't have any files from beta down to central
http://l10n.mozilla-community.org/~flod/p12n/errors/?product=browser
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Assignee

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.