Requesting a loaner machine b2g_ubuntu64_vm to diagnose bug 1017490

RESOLVED FIXED

Status

Release Engineering
Loan Requests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: yurenju, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [buildduty][loaner])

I need a loaner machine of type b2g_ubuntu64_vm. In order to diagnose bug 1017490 because xulrunner got Segmentation fault[1][2] and I can't reproduce locally.


[1] https://tbpl.mozilla.org/?tree=Gaia-Try&rev=a1159eb03a1e
[2] https://tbpl.mozilla.org/php/getParsedLog.php?id=41663731&tree=Gaia-Try
Summary: Requesting a loaner machine b2g_ubuntu64_vm to diagnose bug 887761 → Requesting a loaner machine b2g_ubuntu64_vm to diagnose bug 1017490
See Also: → bug 1017490
No longer blocks: 887761
No longer depends on: 892318, 892335, 892507

Updated

3 years ago
Assignee: nobody → sbruno

Updated

3 years ago
Assignee: sbruno → jlund
I was unable to create a new AWS test instance as per instructions here: https://wiki.mozilla.org/ReleaseEngineering/How_To/Loan_a_Slave#AWS_machines

Namely, I got the following exception:

2014-06-13 10:20:28,398 - ERROR - Bad PTR for tst-linux64-ec2-yurenju
Traceback (most recent call last):
  File "cloud-tools/scripts/aws_create_instance.py", line 425, in <module>
    verify(args.hosts, config, args.region, args.ignore_subnet_check)
  File "cloud-tools/scripts/aws_create_instance.py", line 64, in verify
    raise RuntimeError("Sanity check failed")
RuntimeError: Sanity check failed

Assigning to jlund as the next relenger in the buildduty schedule (sorry man!)
simone - I am seeing two pairs of A/PTR records for tst-linux64-ec2-yurenju.test.releng.use1.mozilla.com

did you run invtool twice? If not, maybe yurenju already has a machine on loan with this fqdn.
Flags: needinfo?(sbruno)
ok. so I see three inventory records for: yurenju

tst-linux64-ec2-yurenju.dev.releng.use1.mozilla.com
tst-linux64-ec2-yurenju.test.releng.use1.mozilla.com
tst-linux64-ec2-yurenju.test.releng.use1.mozilla.com (different ip)

looking at the details of each, they all point to this bug...

I will look again when I am on buildduty on monday or if my queue today clears.
Hi jlund, that's my fault: I invoked invtool multiple times by mistake (you see why I needed a holiday!).
Flags: needinfo?(sbruno)
OK, will resolve this morning.

I neglected to check for build machines. There are two:
dev-linux64-ec2-yurenju.dev.releng.use1.mozilla.com (points to this bug as well)
dev-linux64-ec2-yurenju1.dev.releng.use1.mozilla.com (points to https://bugzilla.mozilla.org/show_bug.cgi?id=892318)


I will be removing the following records:
dev-linux64-ec2-yurenju1 -> instance was deleted, bug resolved months ago. also will remove vpn access list.
dev-linux64-ec2-yurenju -> not needed for this bug, we need a test slave.
tst-linux64-ec2-yurenju.dev.releng.use1.mozilla.com
tst-linux64-ec2-yurenju.test.releng.use1.mozilla.com (ip 10.134.157.91)

I will keep and use:
tst-linux64-ec2-yurenju.test.releng.use1.mozilla.com (ip 10.134.58.55)
Email sent to yju@mozilla.com for further instructions. 

Loaning slaves: 
    - tst-linux64-ec2-yurenju.test.releng.use1.mozilla.com

Hi Yuren, I am going to assign this to you to keep track of the loan(s). 

When you are finished with the loan(s) forever, please comment stating so and mark this bug as resolved.

By the way, now that this aws instance has been created, starting and stopping it can happen in a flash!
If you are not going to be using this machine for multiple hours, let us know in this bug and we can stop it.
Comment again when you want it started back up.
*For really fast turnaround, ping #releng (look for nick with 'buildduty')

Side note, I had to delete all previous A/PTR records as they had conflicting values.
Assignee: jlund → yurenju.mozilla
Status: NEW → ASSIGNED
Blocks: 1026038
I haven't found the root cause for bug 1017490 but I won't use it for several hours, so please stop it and I will request to start tomorrow.

BTW, do we have buildduty for asia timezone?
Flags: needinfo?(jlund)
(In reply to Yuren [:yurenju] from comment #7)
> I haven't found the root cause for bug 1017490 but I won't use it for
> several hours, so please stop it and I will request to start tomorrow.
> 
> BTW, do we have buildduty for asia timezone?

Outside of North America we usually have 3 release engineers in Europe and 1 in New Zealand who have the powers to start and stop slaves. I have stopped this one for now. If I don't hear from you by the end of my day (5pm PT), I'll start it up again in case no one is around when you are back online.
Flags: needinfo?(jlund)
slave is back on
I have done my investigating for bug 1017490 but I may use the loaner machine for further debugging, could we stop it several days and destroy it if we solved the bug?
Flags: needinfo?(jlund)
instance has been stopped. Leaving bug open.

Yuren, no problem. this should be fine for the next week or so. Either request you want it turned back on again or resolve this bug if you are done with it forever.
Flags: needinfo?(jlund)
:jlund, the issue has been resolved, you can destory the virtual machine, thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jlund)
Resolution: --- → FIXED
awesome thanks. Assigning to this week's buildduty
Assignee: yurenju.mozilla → coop
Flags: needinfo?(jlund)
Assignee: coop → nobody
Blocks: 1053688
No longer blocks: 1053688
You need to log in before you can comment on or make changes to this bug.