Feature Request: Add support for role="none" in ARIA 1.1

RESOLVED DUPLICATE of bug 971212

Status

()

RESOLVED DUPLICATE of bug 971212
4 years ago
4 years ago

People

(Reporter: richschwer, Unassigned)

Tracking

(Blocks: 1 bug, {access})

Trunk
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

We added a synonymous role for role="presentation" in ARIA 1.1. This was done to reduce the amount of typing needed to support this function and to create a new role that was better understandable to page authors. Over some considerable time role="presentation" should be deprecated out. See: http://rawgit.com/w3c/aria/master/spec/aria.html#none


Actual results:

This is a new ARIA feature.


Expected results:

This is a new ARIA feature and it should be implemented the same as role="presentation"
(Reporter)

Updated

4 years ago
Keywords: access
Marco, David, any concerns? I didn't follow this topic close but I think I'm ok with 'none' role as the way to remove semantics.
Blocks: 343213
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → Disability Access APIs
Product: Firefox → Core
OS: Mac OS X → All
Hardware: x86 → All
Version: 29 Branch → Trunk
(In reply to alexander :surkov from comment #1)
> Marco, David, any concerns? I didn't follow this topic close but I think I'm
> ok with 'none' role as the way to remove semantics.

I'm okay with it but I'd prefer this fixed in bug 971212.

Comment 3

4 years ago
No objections, and I agree with David.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 971212
You need to log in before you can comment on or make changes to this bug.