Implement ARIA role=none

RESOLVED FIXED in Firefox 38

Status

()

Core
Disability Access APIs
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: davidb, Assigned: surkov)

Tracking

(Blocks: 1 bug)

unspecified
mozilla38
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox38 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
From minutes: http://www.w3.org/2014/02/11-aapi-minutes.html

Comment 1

3 years ago
In sharing the new role proposal with some devs, many incorrectly associated role=none with display:none because they share the same value.
(Assignee)

Comment 2

3 years ago
(In reply to Bryan Garaventa from comment #1)
> In sharing the new role proposal with some devs, many incorrectly associated
> role=none with display:none because they share the same value.

It's better go to w3c ARIA mail list where the discussion of this topic takes place, for example, http://lists.w3.org/Archives/Public/wai-xtech/2014Jan/0009.html

Updated

3 years ago
Duplicate of this bug: 1025027

Comment 4

3 years ago
Info from Rich from bug 1025027 comment #0:

We added a synonymous role for role="presentation" in ARIA 1.1. This was done to reduce the amount of typing needed to support this function and to create a new role that was better understandable to page authors. Over some considerable time role="presentation" should be deprecated out. See: http://rawgit.com/w3c/aria/master/spec/aria.html#none

Comment 5

2 years ago
Alex, do you have role="none" implemented?
(Assignee)

Comment 6

2 years ago
Created attachment 8565688 [details] [diff] [review]
patch
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #8565688 - Flags: review?(dbolter)
(Assignee)

Comment 7

2 years ago
(In reply to Rich Schwerdtfeger from comment #5)
> Alex, do you have role="none" implemented?

mostly :)
Summary: Implement ARIA role=none? → Implement ARIA role=none
(Reporter)

Comment 8

2 years ago
Comment on attachment 8565688 [details] [diff] [review]
patch

Review of attachment 8565688 [details] [diff] [review]:
-----------------------------------------------------------------

Alrighty.
Attachment #8565688 - Flags: review?(dbolter) → review+
https://hg.mozilla.org/mozilla-central/rev/06d87431a1ae
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox38: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.