Closed Bug 1025169 Opened 6 years ago Closed 6 years ago

[System] An activity iframe does not have the focus until the user taps the window

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.0+)

RESOLVED DUPLICATE of bug 1021270
blocking-b2g 2.0+

People

(Reporter: julienw, Unassigned)

Details

(Keywords: regression)

STR:
1. have a build with the patch for bug 1018035 (probably optional, but without this patch we don't see the caret)
2. launch contacts (with at least one contact)
3. tap a contact with a phone number
4. tap the 'send sms' button

Expected:
* the message input gets the focus

Actual:
* it does not

When using the app manager and running the following command in the System app:

  document.querySelector('.activityWindow iframe').focus()

then the input gets the focus. That's why I think it's a System bug.

A regression window could be useful but take care because the focus for this activity didn't work until bug 978553.
Flags: needinfo?(alive)
Julien, I guess my work in bug 1021270 fixes the focus, do you have it in your build?
Flags: needinfo?(alive)
NI me to check the STR with the latest build
Flags: needinfo?(felash)
Yep, I don't see the issue with the current master, thanks a lot Alive !
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(felash)
Resolution: --- → DUPLICATE
Duplicate of bug: 1021270
blocking-b2g: 2.0? → 2.0+
You need to log in before you can comment on or make changes to this bug.