Closed Bug 1025178 Opened 5 years ago Closed 5 years ago

[everything.me] Search results that have globe icons don't open

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: vtsatskin, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
amirn
: review+
Details | Review
Device    Flame
Gaia      1b5557e5b9e2e194a466efd9bf91985efe311591
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/f1aebc2f1c58
BuildID   20140613061552
Version   32.0a2
ro.build.version.incremental=eng.cltbld.20140606.192117
ro.build.date=Fri Jun  6 19:21:29 EDT 2014

# Steps to reproduce

1) Enter a search term (e.g. "testing")
2) Click any result icon in the top row

# Expected Results

Pressing the icon opens the result

# Actual Results

Nothing happens.

# Frequency

Every time for all search terms
blocking-b2g: 2.0? → 2.0+
Whiteboard: [systemsfe]
Currently unable to reproduce. Adding qawanted to see if there is a STR here, and if so, logcat or video.
Keywords: qawanted
Moving to just qawanted to verify on the latest 2.0 build.
Component: Gaia::Everything.me → Gaia::Search
If reproducible this would be a FL blocker, but I think this will be a wfm.
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+]
Valentin,
      I have been able to reproduce this issue but have a question for you. I can repro this bug if websites use the Universal icons(globe). However if the website uses unique icons such as the Youtube, wikipedia icons, the bug does not happen.

Is there anyway that all the icons you were tapping on were the Universal (Globe) icons?

Example:
I typed in Testing into E.me and all websites that appeared had unique icons for their websites and the bug does NOT repro.

I typed in Testingp into E.me and see several universal (Globe) icons that do cause this issue you describe.

Here is a video for reference. Please let me know if i'm on the correct path here as I cannot get this bug without the globe icons appearing.
http://youtu.be/A8V8lcoKmHA
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+] → [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage?]
Flags: needinfo?(vtsatskin)
Pressing Globe icons cause the issue I described. Looks like I may have been mistaken initially when filling this bug. The top row must have had only globe icons leading me to to think the entire top row doesn't work.
Flags: needinfo?(vtsatskin)
QA Whiteboard: [VH-FL-blocking+][VH-FC-blocking+][QAnalyst-Triage?] → [VH-FL-blocking-][VH-FC-blocking+][QAnalyst-Triage?]
Keywords: qawanted
Summary: [everything.me] Top row of search results don't open → [everything.me] Search results that have globe icons don't open
Blocks: 1015336
No longer blocks: vertical-homescreen
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.0 S4 (20june)
Attached file Github pull request
Dale - Root cause was that we were not passing in a proper ID (the id from E.me can come back null). When this happens we are unable to find the proper object via bubbling in gaia-grid. I obviously want to add a test, but I would like to wait until bug 1025586 lands so we have a solid starting point.
Attachment #8441144 - Flags: review?(dale)
maybe we should ignore the id E.me sends and use the url as an identifier instead for consistency
Flags: needinfo?(ran)
Might it clash with a homescreen bookmark of the same url?
Flags: needinfo?(ran)
(In reply to Ran Ben Aharon (Everything.me) from comment #8)
> Might it clash with a homescreen bookmark of the same url?

That might actually be useful for deduping.
Comment on attachment 8441144 [details] [review]
Github pull request

(In reply to Ran Ben Aharon (Everything.me) from comment #8)
> Might it clash with a homescreen bookmark of the same url?

Good point. Right now this is only for the search app and everything gets deduped anyway - so it's not on the screen. 

If you guys have some time to review this simple that would be great :)
Attachment #8441144 - Flags: review?(ran)
Attachment #8441144 - Flags: review?(amirn)
Attachment #8441144 - Flags: review?(ran)
Attachment #8441144 - Flags: review?(dale)
Attachment #8441144 - Flags: review?(amirn)
Attachment #8441144 - Flags: review+
Thanks! Landed: https://github.com/mozilla-b2g/gaia/commit/0e1a7b33a47271a672f6449c80b62b9d7f1082f8

I'm also going to work on some integration tests for this as well.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
I hit a condition and would be resolved in the next build: https://bugzilla.mozilla.org/show_bug.cgi?id=1026716#c3

Verified fixed : 
Gaia      82e957160ca017087bd374cd051339e55b641e68
Gecko     https://hg.mozilla.org/mozilla-central/rev/f78e532e8a10
BuildID   20140619040201
Version   33.0a1
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
Flame
Status: RESOLVED → VERIFIED
Verified on 2.0:

Gaia      23e06c3624309db22ad9cb736d89700768b42b36
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/164b61458ca5
BuildID   20140619000200
Version   32.0a2
ro.build.version.incremental=108
ro.build.date=Tue Jun 10 19:40:40 CST 2014
flame
You need to log in before you can comment on or make changes to this bug.