Closed Bug 1025874 Opened 5 years ago Closed 5 years ago

[GTK3] Build failure in moz_gtk_get_focus_outline_size()

Categories

(Core :: Widget: Gtk, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla33

People

(Reporter: stransky, Assigned: stransky)

References

Details

Attachments

(1 file)

A regression from Bug 427928
Attached patch patchSplinter Review
w->style can't be used on gtk3. 

It comes from https://bug427928.bugzilla.mozilla.org/attachment.cgi?id=8438630
Attachment #8440666 - Flags: review?(karlt)
Comment on attachment 8440666 [details] [diff] [review]
patch

Thank you.

BTW, I suspect focus_width should not be involved when interior_focus, because gtk_render_focus is not used in that case.  Also, I suspect gtk_render_frame should not be called when (!interior_focus && draw_focus_outline_only), like the gtk2 code.  But those are separate issues.
Attachment #8440666 - Flags: review?(karlt) → review+
Thanks. Let's fix the build issue first.
Keywords: checkin-needed
hi, could you provide a try link for this checkin ?
Keywords: checkin-needed
The patch touches code that isn't built by default.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/776181d387b1
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Blocks: 1034064
No longer blocks: 1034064
You need to log in before you can comment on or make changes to this bug.