Port GTK2 to GTK3 - Can't click in Flash settings

RESOLVED WORKSFORME

Status

()

Core
Widget: Gtk
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Bryan Quigley, Assigned: stransky)

Tracking

({meta})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #627699 +++

1. Load a youtube video that forces Flash (Ex: https://www.youtube.com/watch?v=bN5AXq4WvZI).
2. Right click on the youtube video
3. Go to Settings.
4. Try to click things with the mouse.
Note: You can use Tab to navigate the window.


Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0 - using July 3rd built from here: https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/elm-linux64/latest/
(Reporter)

Updated

4 years ago
(Reporter)

Updated

4 years ago

Updated

4 years ago
Whiteboard: [leave open as a tracking bug][please file new bugs for additional patches]]
(Assignee)

Comment 1

3 years ago
Uff. After figuring out how to disable html5 on youtube (set media.webm.enabled to false :)) I'm unable to reproduce this issue. Do you see any error message on console and/or debug output?
Flags: needinfo?(gQuigs+bugs)
(Assignee)

Updated

3 years ago
Assignee: nobody → stransky
(Reporter)

Comment 2

3 years ago
I can't get a recent build to load flash per bug 1051209.  Will retry when that fix lands.
(Assignee)

Comment 3

3 years ago
Just build trunk with the patch applied... (by hg import -p1 patch_name).
Works for me using - http://people.mozilla.org/~kbrosnan/tmp/1034064/firefox-35.0a1.en-US.linux-x86_64.tar.bz2

Which is a pull of m-c from 30 min ago, --enable-default-toolkit=cairo-gtk3 --without-system-nspr --without-system-nss --enable-gstreamer=1.0 and the patch from bug 1051209.
(Reporter)

Comment 5

3 years ago
@kbrosnan.. Thanks for the build! I confirm it's fixed as well.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gQuigs+bugs)
Resolution: --- → FIXED
We don't know what fixed this, wfm.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.