Closed Bug 1026133 Opened 6 years ago Closed 4 years ago

Get e10s mochitest-plain tests running in automation on Windows

Categories

(Firefox :: General, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1215233
Tracking Status
e10s + ---

People

(Reporter: jimm, Assigned: jimm)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

To do:

- Take a look at both debug and release test runs with e10s enabled to see how they stand.
- Fix or disable to get green test runs
- enable e10s tests for Windows on all trees
tracking-e10s: --- → ?
https://tbpl.mozilla.org/?tree=Holly

opt mochitest 1-5 look like the lowest hanging fruit.
I finally tracked down the cause of those blanket Win XP opt failures, the problem is with the child inheriting the parent's std handles. Actually the current behavior is expected, we landed some work to get stdout linked up in bug 875210 (with some follow up work in bug 875214) where we basically punted on getting this to work in XP. I think there's probably a way to get this working (maybe through DuplicateHandle when we launch the child?) but it's not critical. Probably better to spend time on other mochitest-plain failures for now and ignore XP opt. 

Unfortunately I've spent too much time tracking this down and now I've got some m1 work to catch up on.. will return to this and other test failures next week once my m1 blockers are in review.
Depends on: 875210
No longer depends on: 875210
Depends on: 1037445
Depends on: 1041695
Depends on: 1043597
Depends on: 998501
Summary: Get e10s mochitest tests running in automation on Windows → Get e10s mochitest-plain tests running in automation on Windows
Depends on: 1053993
Depends on: 1065881
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1215233
You need to log in before you can comment on or make changes to this bug.