Last Comment Bug 1215233 - Schedule e10s tests on Windows 7
: Schedule e10s tests on Windows 7
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: Unspecified Unspecified
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 1026133 1069471 1122901 1171188 (view as bug list)
Depends on: 1217493 1219434 1219437 1219816 1221102 1221499 1226729 1232780 1239025 1239785 1240825 1245559 1246451 1246453 1246627 1248729 1249376 1251351 1252258
Blocks: e10s-tests e10s-rc
  Show dependency treegraph
 
Reported: 2015-10-15 11:28 PDT by Jonathan Griffin (:jgriffin)
Modified: 2016-04-11 10:11 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments

Description User image Jonathan Griffin (:jgriffin) 2015-10-15 11:28:05 PDT
The e10s team would like us to schedule e10s tests on Windows; we're currently only running mochitest-browser-chrome on Win7 opt and Win8 opt. Since these platforms are already over capacity, we'll likely do this periodically and piecemeal, and this bug will act as a tracking bug.
Comment 1 User image Jonathan Griffin (:jgriffin) 2015-10-15 11:28:29 PDT
Blake, what suite should we target first here?
Comment 2 User image Jonathan Griffin (:jgriffin) 2015-10-15 11:47:47 PDT
Candidates are: mochitest-plain, mochitest-devtools-chrome, reftests, crashtests, jsreftests, web-platform-tests, web-platform-reftests, Marionette, update-tests, media-tests
Comment 3 User image Jonathan Griffin (:jgriffin) 2015-10-26 11:40:13 PDT
It looks like the current status of Windows tests on e10s is unknown. I've just merged m-c to holly (last done in July!) to see where we're at; chances are there will be some work needed by the e10s team to fix or disable tests before we can look at turning them on for try or trunk branches.

https://treeherder.mozilla.org/#/jobs?repo=holly
Comment 4 User image Jonathan Griffin (:jgriffin) 2015-10-26 13:05:50 PDT
Looks like tests on holly have been turned off, so we'll need to do this on try. What prefs do I flip to accomplish this?
Comment 5 User image Jim Mathies [:jimm] 2015-10-26 13:20:36 PDT
The mozharness config files moved so my old config patch is bitrotten. Looks like the new files are here - 

http://mxr.mozilla.org/mozilla-central/source/testing/mozharness/configs/unittests/

Looks like we can add '--e10s' to suite_definitions for the suites we want e10s turned on in. jittest, mochitest, and reftest look like the right candidates.
Comment 6 User image Jonathan Griffin (:jgriffin) 2015-10-26 13:48:47 PDT
That's not exactly what I mean; I mean, which prefs do we need to flip in order to have the browser running in e10s mode regardless of whether we pass --e10s or not? That's the best way to make a try run for something like this.
Comment 7 User image Jonathan Griffin (:jgriffin) 2015-10-26 15:48:25 PDT
ghetto try run with the --e10s hack for mochitests: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6fe342dcb884
Comment 8 User image Jonathan Griffin (:jgriffin) 2015-10-27 09:18:12 PDT
The try run isn't looking too good! Looks like a fair amount of work is needed to green up mochitest-plain; mochitest-devtools-chrome looks like the easiest to clean up.

Jim, I'm passing this back to you; as soon as these suites are green we can turn them on more broadly, but not until then. Let me know if there's anything else you need in the meantime.
Comment 9 User image Jim Mathies [:jimm] 2015-10-27 09:22:33 PDT
Blake is heading this aspect of the project up so I will defer to him on what to do next. FWIW I've got twalker working on adding browser chrome, I'm not aware of anyone working on mochitest-plain, and dev tools tests are the responsibility of the dev tools team.
Comment 10 User image Jonathan Griffin (:jgriffin) 2015-10-27 09:41:49 PDT
How we're currently planning on freeing up enough capacity on Windows test machines in order to enables e10s tests, after they're green: https://groups.google.com/forum/#!topic/mozilla.tools/kihsolW9IQE
Comment 11 User image Blake Kaplan (:mrbkap) 2015-10-27 18:35:18 PDT
I don't thinks are as dire as comment 8 suggests. It looks like there might be one or two tests per mochitest chunk that are failing, causing everything to be orange but relatively little work to make each chunk not be. I'll start filing bugs (leaving the needinfo to do that) on making these green.
Comment 12 User image Jonathan Griffin (:jgriffin) 2015-11-03 03:45:06 PST
*** Bug 1171188 has been marked as a duplicate of this bug. ***
Comment 13 User image Jonathan Griffin (:jgriffin) 2015-11-03 03:49:27 PST
new try run to check status: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f439ce85793b
Comment 14 User image Jim Mathies [:jimm] 2015-11-03 04:16:47 PST
*** Bug 1026133 has been marked as a duplicate of this bug. ***
Comment 15 User image Jim Mathies [:jimm] 2015-11-03 04:18:44 PST
*** Bug 1069471 has been marked as a duplicate of this bug. ***
Comment 16 User image Jim Mathies [:jimm] 2015-11-03 04:21:58 PST
*** Bug 1122901 has been marked as a duplicate of this bug. ***
Comment 17 User image Jonathan Griffin (:jgriffin) 2015-11-03 06:21:02 PST
(In reply to Jonathan Griffin (:jgriffin) from comment #13)
> new try run to check status:
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=f439ce85793b

mochitest-gl is ready to turn on now, mochitest-devtools-chrome is close; just a few failures remaining. More works is needed on mochitest-plain and reftest.
Comment 18 User image Jonathan Griffin (:jgriffin) 2015-11-05 05:29:18 PST
New try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fcc0bbf423dd
Comment 19 User image Erin Lancaster [:elan] 2016-04-06 11:46:01 PDT
This is running, now https://wiki.mozilla.org/Electrolysis/Test_Coverage. jgriffin can we resolve this as fixed or do we need to wait until we have capacity problems resolved.
Comment 20 User image Jonathan Griffin (:jgriffin) 2016-04-11 10:09:05 PDT
There are two suites not running on Windows 7 debug due to unresolved leaks or crashes. But I think it's ok to leave this metabug marked as fixed.
Comment 21 User image Ryan VanderMeulen [:RyanVM] 2016-04-11 10:11:52 PDT
Yeah, future work can happen under bug 1253849.

Note You need to log in before you can comment on or make changes to this bug.