Add Twitter logo to search plugin so about:newtab can use it

VERIFIED FIXED in Firefox 31

Status

()

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: adw, Assigned: adw)

Tracking

Trunk
Firefox 33
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox30 unaffected, firefox31 verified, firefox32 verified, firefox33 verified)

Details

(Whiteboard: p=1 s=33.1 [qa!])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8441070 [details] [diff] [review]
patch

(In reply to Joanne Nagel from bug 1006203 comment #15)
> As we discussed previously, I don't have agreements with Twitter or
> Wikipedia, so we should be able to use whatever assets they have published
> online.

This patch uses the images Boriss posted to bug 962490 comment 34.

Matt, this patch is similar to the one you reviewed in bug 1009299.
Attachment #8441070 - Flags: review?(MattN+bmo)
(Assignee)

Comment 1

4 years ago
Marco, could we add this to the current iteration, please?
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
Whiteboard: p=1
Added to Iteration 33.1
Flags: needinfo?(mmucci)
Whiteboard: p=1 → p=1 s=33.1 [qa?]
Attachment #8441070 - Flags: review?(MattN+bmo) → review+

Updated

4 years ago
Whiteboard: p=1 s=33.1 [qa?] → p=1 s=33.1 [qa+]
https://hg.mozilla.org/mozilla-central/rev/9f240286039b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
QA Contact: petruta.rasa
Verified as fixed on latest Nightly 33.0a1 2014-06-18 under Win 7 64-bit, Ubuntu 12.10 32-bit and Mac OSX 10.8.5.
The logo appears and works as expected.

Shouldn't this be uplifted to Aurora and Beta as the main feature is already in beta, ready for release?
Status: RESOLVED → VERIFIED
Whiteboard: p=1 s=33.1 [qa+] → p=1 s=33.1 [qa!]
(Assignee)

Comment 6

4 years ago
Comment on attachment 8441070 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Bug 962490 added a search field to about:newtab and landed on 31.  The logo of the currently selected search engine, if available, appears to the left of the search field.

User impact if declined:
When Twitter is the currently selected engine, its logo will not appear.  about:newtab gracefully handles missing logos, though.

Testing completed (on m-c, etc.):
manual testing, automated testing on m-c

Risk to taking this patch (and alternatives if risky):
very low

String or IDL/UUID changes made by this patch:
none
Attachment #8441070 - Flags: approval-mozilla-beta?
Attachment #8441070 - Flags: approval-mozilla-aurora?
Attachment #8441070 - Flags: approval-mozilla-beta?
Attachment #8441070 - Flags: approval-mozilla-beta+
Attachment #8441070 - Flags: approval-mozilla-aurora?
Attachment #8441070 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 7

4 years ago
Aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/0cd501f8ba51
Beta: https://hg.mozilla.org/releases/mozilla-beta/rev/cc6044083858
status-firefox30: --- → unaffected
status-firefox31: --- → fixed
status-firefox32: --- → fixed
status-firefox33: --- → fixed
status-firefox33: fixed → verified
Whiteboard: p=1 s=33.1 [qa!] → p=1 s=33.1 [qa+]
Verified as fixed using Firefox 31 beta 3 and latest Aurora 32.0a2 20140622004004 under Win 7 64-bit, Ubuntu 13.04 64-bit and Mac OSX 10.9.2.
status-firefox31: fixed → verified
status-firefox32: fixed → verified
Whiteboard: p=1 s=33.1 [qa+] → p=1 s=33.1 [qa!]
You need to log in before you can comment on or make changes to this bug.