Closed Bug 1006203 Opened 8 years ago Closed 8 years ago

Add remaining search provider logos to about:newtab

Categories

(Firefox :: New Tab Page, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 33

People

(Reporter: adw, Unassigned)

References

Details

(Keywords: meta)

Attachments

(4 files)

Bug 962490 added Amazon and Bing logos.  Let's use this bug to track the remaining logos.

attachment 8415577 [details] from bug 962490 already has the Yahoo logo, which has not landed, but it's only high-DPI.  Right now the code expects both high- and low-DPI logos to be present.  I'd like to tweak that so that the high-DPI is used and resized in low-DPI situations when a low-DPI logo is absent.
Are we planning to include DuckDuckGo and/or DuckDuckGo Next logos? Should I file a new bug for that?
(In reply to Drew Willcoxon :adw from comment #0)
> Bug 962490 added Amazon and Bing logos.  Let's use this bug to track the
> remaining logos.

Can you define "remaining logos"? I see bug 962490 added very peculiar images to XML files (65x26, 130x52).
What's your plan for l10n searchplugins?
Attached image Beta images
I count 118 images (on beta).
These are the logos that appear at the start of the search bar inside about:newtab, not favicons.  These are only to support the initial scope of bug 962490, which has context.  I think the remaining logos are for eBay, Google, Twitter, and Wikipedia, but Joanne and Bryan would know for sure.  Once those are landed, I'll close this bug.

I don't know what Joanne and Bryan's localization plans are, if any, but the only thing that needs to be done to make some other plugin's logo appear is to add it to the plugin's XML.
Let me clarify: those 118 images are mapped to 118 different searchplugins we're shipping with localized versions of Firefox.

Adding eBay, Google, Twitter, and Wikipedia will fix en-US, but leave all the other locales in a limbo of missing images.

It would be nice for once to start thinking from the beginning to what will happen to localized builds (or searchplugins added by users directly from websites). I'm looking at the specs but I don't see anything about that.
Flags: firefox-backlog+
Bug 962490 should ship with 31. Will this bug land in 31 too?
Flags: needinfo?(adw)
(In reply to Francesco Lodolo [:flod] from comment #5)
> Let me clarify: those 118 images are mapped to 118 different searchplugins
> we're shipping with localized versions of Firefox.

I think we're finalized on the logo requirements, can you help us send out a message to the l10n community to get this process started?  Also, how did you generate that?  It's awesome.

> Adding eBay, Google, Twitter, and Wikipedia will fix en-US, but leave all
> the other locales in a limbo of missing images.

The input is designed to handle this issue and will use the text instead.  It's not ideal but works for the interim, Google doesn't currently have an icon yet. 

> It would be nice for once to start thinking from the beginning to what will
> happen to localized builds (or searchplugins added by users directly from
> websites). I'm looking at the specs but I don't see anything about that.

We need to get something up on the wiki (or mdn?) about this, now is probably the right time to do it.

Any search engine plugin should be able to provide an image for this location with the following image tags in their OpenSearch XML description:

<!-- Favicon size for search input bar -->
<Image width="16" height="16"></Image>
<!-- New Tab search input icon -->
<Image width="65" height="26"></Image>
<!-- Mac Retina size New Tab search input icon -->
<Image width="130" height="52"></Image>
(In reply to Bryan Clark (Firefox Search PM) [:clarkbw] from comment #7)
> I think we're finalized on the logo requirements, can you help us send out a
> message to the l10n community to get this process started?  Also, how did
> you generate that?  It's awesome.

Searchplugins update it's usually me doing mass updates, but this is not the kind of thing I can do (or I can try to script that for the same searchplugins en-US has, not for the rest). Also, technically all searchplugins changes not done by l10n-drivers require patch+review.

About the image
http://l10n.mozilla-community.org/~flod/p12n/collage/

And these are the scripts generating it
https://github.com/flodolo/scripts/tree/master/productization

> The input is designed to handle this issue and will use the text instead. 
> It's not ideal but works for the interim, Google doesn't currently have an
> icon yet. 

OK. Any plan on showing at least the favicon we have, if the other images are missing?
(In reply to Sylvestre Ledru [:sylvestre] from comment #6)
> Bug 962490 should ship with 31. Will this bug land in 31 too?

The remaining logos we expect to land are for Yahoo, eBay, Google, Twitter, and Wikipedia.  Once each logo is ready, I'm thinking I'll file a separate bug for it, mark the bug as blocking this one, land the logo there, and then close the bug.  I'll request uplift all the way back to 31 where possible.  That should make it easier to keep track of when each landed instead of keeping this bug open indefinitely while some logos have landed and others haven't, possibly spanning multiple releases.

The Yahoo logo is ready but I haven't filed a bug for it yet.
Flags: needinfo?(adw)
(In reply to Francesco Lodolo [:flod] from comment #8)
> (In reply to Bryan Clark (Firefox Search PM) [:clarkbw] from comment #7)
> > I think we're finalized on the logo requirements, can you help us send out a
> > message to the l10n community to get this process started?  Also, how did
> > you generate that?  It's awesome.
> 
> Searchplugins update it's usually me doing mass updates, but this is not the
> kind of thing I can do (or I can try to script that for the same
> searchplugins en-US has, not for the rest). Also, technically all
> searchplugins changes not done by l10n-drivers require patch+review.

Given the size of the list I think we need to put docs together on how to fix it and look to the search engine provider to come to us with the correct image.  If you have a short list of important places I can reach out directly to those groups.

> About the image
> http://l10n.mozilla-community.org/~flod/p12n/collage/
> 
> And these are the scripts generating it
> https://github.com/flodolo/scripts/tree/master/productization

Nice!

> > The input is designed to handle this issue and will use the text instead. 
> > It's not ideal but works for the interim, Google doesn't currently have an
> > icon yet. 
> 
> OK. Any plan on showing at least the favicon we have, if the other images
> are missing?

The favicon will only show in the search input but not on the new tab page.  I believe ux tried a version  using the favicon as a fallback but didn't feel like it worked well enough given the size requirements.  There is likely another solution there we haven't tried.
Depends on: 1009299
Mass-move to Firefox::New Tab Page.

Filter on new-tab-page-component.
Component: General → New Tab Page
I added Bug 1014076 which is partly about this but also other issues about the current implementation of the search provider switcher. Sorry if it should have been here instead.
> The favicon will only show in the search input but not on the new tab page. 
> I believe ux tried a version  using the favicon as a fallback but didn't
> feel like it worked well enough given the size requirements.  There is
> likely another solution there we haven't tried.

I have working code that displays the favicon+name in the button when there is no logo. It looks like this:
Attachment 8429442 [details].

I can upload the corresponding patch, or change it to implement any other design solution the UX team wants.
Hey Joanne, wanted to follow up on these images.

Still missing images for:
* google
* ebay
* twitter
* wikipedia

I'm assuming Boriss can make the Wikipedia from the creative we already have.
Flags: needinfo?(jnagel)
Hey Bryan,

I sent instructions for Google to you & Boriss back on April 17th, do you need me to resend or are you asking for something different?

I've attached the Yahoo image, sorry, I was sure I'd sent that out.

Let me ping eBay again - they recently transitioned to a new BD person and this was dropped.

As we discussed previously, I don't have agreements with Twitter or Wikipedia, so we should be able to use whatever assets they have published online.

Let me know if I missed anything and apologies on the delay.  Thanks, Joanne
Flags: needinfo?(jnagel)
Just found the email from eBay that approved the images that Boriss had setup.
(In reply to Joanne Nagel from comment #15)
> I've attached the Yahoo image, sorry, I was sure I'd sent that out.

We landed Yahoo in bug 1009299.  (Lots of bugs related to newtab search. :-/)

> As we discussed previously, I don't have agreements with Twitter or
> Wikipedia, so we should be able to use whatever assets they have published
> online.

I'll use the ones Boriss posted in bug 962490 comment 34 then.
(In reply to Joanne Nagel from comment #15)
> Hey Bryan,
> 
> I sent instructions for Google to you & Boriss back on April 17th, do you
> need me to resend or are you asking for something different?
Flags: needinfo?(clarkbw)
Depends on: 1026298
Depends on: 1026300
Depends on: 1026301
I filed the following bugs:

* Bug 1026298: Wikipedia
* Bug 1026300: Twitter
* Bug 1026301: eBay

I had a question for Joanne and Borris in the eBay bug, but other than that the only remaining logo is Google.
Keywords: meta
Duplicate of this bug: 1026486
(In reply to :Gavin Sharp (email gavin@gavinsharp.com) from comment #19)
> (In reply to Joanne Nagel from comment #15)
> > Hey Bryan,
> > 
> > I sent instructions for Google to you & Boriss back on April 17th, do you
> > need me to resend or are you asking for something different?

Sorry, you're right, I found the email.  I believe we have the required images, just need to be resized.  Boriss, I'll resend that email to you.  Can you resize them?
Flags: needinfo?(clarkbw) → needinfo?(jboriss)
(In reply to Bryan Clark (Firefox PM) [:clarkbw] from comment #22)
> (In reply to :Gavin Sharp (email gavin@gavinsharp.com) from comment #19)
> > (In reply to Joanne Nagel from comment #15)
> > > Hey Bryan,
> > > 
> > > I sent instructions for Google to you & Boriss back on April 17th, do you
> > > need me to resend or are you asking for something different?
> 
> Sorry, you're right, I found the email.  I believe we have the required
> images, just need to be resized.  Boriss, I'll resend that email to you. 
> Can you resize them?

Yep!
Flags: needinfo?(jboriss)
(maybe this is out of scope, but are these going to be re-used for `about:home`?)
Hopefully eventually: bug 1029889
Depends on: 1030251
(In reply to Jennifer Morrow [:Boriss] (Firefox UX) from comment #25)
> Created attachment 8445508 [details]
> Google Logo Defualt: 65x26 px

Note for others that this image is actually 65x25.
All remaining logos have landed on m-c in the dependent bugs, so resolving fixed.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Flags: firefox-backlog+
Target Milestone: --- → Firefox 33
You need to log in before you can comment on or make changes to this bug.