Closed Bug 1026341 Opened 6 years ago Closed 6 years ago

[Dialer][Call Screen][Flame] Some space, a thin line, not covered by name, number white background

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: echang, Assigned: paco)

Details

(Keywords: regression)

Attachments

(7 files, 2 obsolete files)

### STR
1. Have a entry in Contacts with or without photo.
2. Make outgoing call to number in step1 or receiving a call from it.

### Actual result
1. Some space, a thin line, not covered by name, number white background
2. See CallScreenWhiteLine.png, CallScreenWhiteLineHangup.png

### Expected result
1. Space covered as Buri does.
2. See CallScreenBuriOkay.png, CallScreenBuriHangupOkay.png


### Version
Gaia      0f254c92bc44d614ae56a855f18a895a7e4703ad
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/301e62e44f18
BuildID   20140616160201
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
t2m.sw.version=B1TC00011220
Attached image CallScreenBuriOkay.png
Paco, can you have a look at it?
Flags: needinfo?(pacorampas)
Assignee: nobody → pacorampas
Flags: needinfo?(pacorampas)
Attached file patch in github
Attachment #8443398 - Flags: review?(anthony)
Paco, can you ask Etienne for the revision as Anthony is on PTO? Thanks
Flags: needinfo?(pacorampas)
Target Milestone: --- → 2.0 S5 (4july)
Attachment #8443398 - Flags: review?(anthony) → review?(etienne)
Flags: needinfo?(pacorampas)
Comment on attachment 8443398 [details] [review]
patch in github

Can you explain the fix a bit?
Are sizing it wrong? Should we set the background on the parent?
Attachment #8443398 - Flags: review?(etienne)
On devices with resolution 1.5 or above on the name field, the letters like "y" or "g" are cut on bottom. Then, my solution was change overflow hidden by overflow visible, and now the cutting area disappear. I have decided for this solution because it doesn't change the design. But other solution is changed the height, for example.
(In reply to Paco Rampas [:paco] from comment #8)
> On devices with resolution 1.5 or above on the name field, the letters like
> "y" or "g" are cut on bottom.

But is this the bug we're trying to fix here?

> Then, my solution was change overflow hidden
> by overflow visible, and now the cutting area disappear. I have decided for
> this solution because it doesn't change the design. But other solution is
> changed the height, for example.

If we need this kind of workaround we should at least file a follow up bug to clean things up.
Excuse me, you are right. It was my fault. I am going to working to fix it in the right way.
https://bugzilla.mozilla.org/show_bug.cgi?id=1030049
I thought that I've already filed one, anyway, here is the bug for truncation.

(In reply to Etienne Segonzac (:etienne) from comment #9)
> (In reply to Paco Rampas [:paco] from comment #8)
> > On devices with resolution 1.5 or above on the name field, the letters like
> > "y" or "g" are cut on bottom.
> 
> But is this the bug we're trying to fix here?
> 
> > Then, my solution was change overflow hidden
> > by overflow visible, and now the cutting area disappear. I have decided for
> > this solution because it doesn't change the design. But other solution is
> > changed the height, for example.
> 
> If we need this kind of workaround we should at least file a follow up bug
> to clean things up.
(In reply to Eric Chang [:ericcc] [:echang] from comment #11)
> https://bugzilla.mozilla.org/show_bug.cgi?id=1030049
> I thought that I've already filed one, anyway, here is the bug for
> truncation.

I have assigned to me this ;)
Attached image line-bottom.png (obsolete) —
Attached image line-bottom.png (obsolete) —
Attachment #8447004 - Attachment is obsolete: true
Attachment #8443398 - Flags: review?(etienne)
Attached image line-bottom.png
Excuse me for change the shot two times, but I have forgotten remove my phone number of the picture.
Attachment #8447007 - Attachment is obsolete: true
Tested in Hamachi 1.4 and not reproducible:
Gecko-b7cb7d7
Gaia-a054aa2
Comment on attachment 8443398 [details] [review]
patch in github

forwarding to Rik
Attachment #8443398 - Flags: review?(etienne) → review?(anthony)
blocking-b2g: --- → backlog
Comment on attachment 8443398 [details] [review]
patch in github

Yeah for less position absolutes!
Attachment #8443398 - Flags: review?(anthony) → review+
Merged: 530ab2dbf606cc9d6000306c4cf105b4a518fb63

(Merging with Travis red, but the failing test is in clock, nothing to see with that PR)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8443398 [details] [review]
patch in github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): wrong css property
[User impact] if declined: incorrect UI
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8443398 - Flags: approval-gaia-v2.0?
Attachment #8443398 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Verified okay with these 2 builds.
Flame - aurora - v2.0 
Gaia      e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/3f9d7a3a0b7b
BuildID   20140707160206
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

Flame - master - v2.1 
Gaia      1dc9e53393ae4680a174dffa44a958ec564ebbe8
Gecko     https://hg.mozilla.org/mozilla-central/rev/dfef245594b6
BuildID   20140707160202
Version   33.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220
Status: RESOLVED → VERIFIED
Attached image 2014-12-01-15-44-36.png
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141130000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.