Closed Bug 1026488 Opened 6 years ago Closed 6 years ago

PDF viewer OK in FF30 Does not work in FF31b1 if disabled cookies

Categories

(Firefox :: PDF Viewer, defect)

31 Branch
x86
All
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox30 --- unaffected
firefox31 + verified
firefox32 --- unaffected
firefox33 --- unaffected

People

(Reporter: rvjanc, Assigned: yury)

References

Details

(Keywords: regression, Whiteboard: [pdfjs-c-ff-integration][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4679)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140610163407

Steps to reproduce:

Went to this site

http://cdn-www.myharmony.com/files/harmony650-usermanual-en.pdf




Actual results:

In FF30 the document is displayed. In FF31b1 nothing happens.

Also tested this using other sites with the same result.
Just checked this in Aurora and it works fine.

Also noticed that in about:config there is an extra preference in 31b

pdfjs.ifAvailableShowOutlineOnLoad --> false

Also in Aurora this preference is there but it is not in 31b

pdfjs.sidebarViewOnLoad --> 0
Just checked in Nightly and it works just fine.
Just checked this in FF31b2. The problem also exists there.
Component: Untriaged → PDF Viewer
Have run some tests and not sure what is going on. Using this for testing

http://cdn-www.myharmony.com/files/harmony650-usermanual-en.pdf

1) Run FF30.0 from default profile -> OK

2) Run FF31b2 from default profile -> DOES NOT DISPLAY

3) Run FF31b2 from default profile in safe mode -> DOES NOT DISPLAY

4) Run FF31b2 with new blank profile -> OK

1) and 2) together would suggest it is not a profile issue. 

However, 3) and 4) would suggest it not an extension issue; but, is a profile issue.

At this point will leave this open and go to mozillazine to look for ideas.
There was something in the prefs.js file that FF31b did not like. After an hour rebuilt and all seems good.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
I have found the issue which causes PDF Viewer to not work in FF31b. 

In Preferences > History when using custom settings, if you DO NOT CHECK "Accept cookies from sites" the PDF Viewer does not render. Note, this is true EVEN IF THERE ARE NO COOKIES REQUIRED. Not sure if this is unique to Mac or not.

This is not an issue for FF30, FF32 (Aurora) and FF33 (Nightly).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
I can reproduce the problem in 31b1 if disabled cookies.

I think that it is worth to fix this in 31beta for next ESR31.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Mac OS X → All
Summary: PDF viewer OK in FF30 Does not work in FF31b1 → PDF viewer OK in FF30 Does not work in FF31b1 if disabled cookies
Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/3d34a3b6443a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140415061201
Bad:
https://hg.mozilla.org/mozilla-central/rev/d969fb1b3c24
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140415091804
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3d34a3b6443a&tochange=d969fb1b3c24

Regressed by: 
076498ab4476	Brendan Dahl — Bug 995431 - Update pdf.js to version 1.0.21. r=yury, r=Mossop, f=RyanVM
Blocks: 995431
Alice, can you bisect to what pdf.js update in Fx32 fixed it? Very much agreed that this needs fixing on 31.
Progression window(m-c)
Bad:
https://hg.mozilla.org/mozilla-central/rev/420f4c65a67f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140509051431
Fixed:
https://hg.mozilla.org/mozilla-central/rev/007380afa681
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140509123830
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=420f4c65a67f&tochange=007380afa681

Seemed fixed by:
970b90975e1c	Ryan VanderMeulen — Bug 1007627 - Update pdf.js to version 1.0.162
Depends on: 1007627
<3 as always :)

Looks like this might be a dupe of bug 1000777, which was fixed in that update.
Critical regression. Tracking.
Comment on attachment 8442790 [details] [diff] [review]
Uplift patch for FF31

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 1007627
User impact if declined: Users that disabled cookies via about:config will not be able view PDF files.
Testing completed (on m-c, etc.): on m-c and aurora
Risk to taking this patch (and alternatives if risky): really low and only affects PDF viewer
String or IDL/UUID changes made by this patch: none
Attachment #8442790 - Flags: approval-mozilla-beta?
Whiteboard: [pdfjs-c-ff-integration][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4679
Attachment #8442790 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Not familiar with the process so please excuse me. What beta release of FF31 is this likely to hit?
Probably beta 3 if it gets uplifted soon (gtb soon). Beta 4 otherwise.
Keywords: checkin-needed
This should get verified once it lands so I'm adding the tag now while I remember to do it.
Keywords: verifyme
Status: NEW → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
So does that mean FF31 release or FF31b4?
RobertJ, that means that it should be part of the 31 beta4 release.
Reproduced the issue based on comment 0 and comment 6, with Firefox 31 Beta 1, 2 or 3.
Verified as fixed on Firefox 31 Beta 4 (Build ID: 20140623175014) on Windows 7 x64, Windows 8 x64, Ubuntu 13.04 x64 and Mac OS X 10.6.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.