Closed Bug 1007627 Opened 6 years ago Closed 6 years ago

Update pdf.js to version 1.0.162

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 32

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #999616 +++

Changes since last update:
#4663 Version 1.0.68
#4645 Only handle scroll events when PDFView.pdfDocument is defined (issue 4642)
#4666 PDFImage_resize: copy in place with alpha and ~5x speed up
#4675 Dutch translations for attachments strings
#4674 Move DocumentOutlineView and DocumentAttachmentsView to their own files
#4671 Guesses Type1C font type based on file content
#4679 [Firefox] Workaround for sessionStorage error when the preference network.cookie.lifetimePolicy is set to 1 (bug 1000777)
#4686 Converts attachment items to buttons instead of links
#4697 Fix the display of the indeterminate progress bar when the loaded percentage is NaN (issue 4696)
#4687 Providing content type for attachment downloads
#4676 Force Unix line endings for text files
#4692 Add support for setting multiple values at once in ViewHistory
#4693 Ensure that the viewer loads even if there are errors when the preferences are read
#4699 Reduces memory used during testing
#4669 Add a preference to set the sidebarView on load
#4689 Fixes DownloadManager for IE10 and above
#4701 Prevent trying to map characters to the specials unicode block in adjustMapping (issue 4650)
#4707 Link to FAQ from startpage
#4700 Reject polyfill and createPromiseCapability
#4705 Refactor how the database is read in ViewHistory
#4716 Amend GlyphMapForStandardFonts to fix issue 4276
#4709 Remove legacy promises from api.js
#4667 Remove LegacyPromise in src/core/chunked_stream.js
#4721 Tiny updates
#4724 Fixes cancel rendering regression
#4730 Fixes disableWorker regression
#4731 Fixes rendering of PDFs with nested trailer dictionary
#4725 Remove LegacyPromise in src/core/pdf_manager.js
#4727 Remove LegacyPromise in src/shared/annotation.js
#4726 Remove LegacyPromise in src/core/core.js
#4728 Remove LegacyPromise in src/core/worker.js
#4729 Remove LegacyPromise
#4733 Completes unit tests for PostScript evaluator and fixes two bugs in the evaluator itself
#4708 Graphic optimizations 1
#4732 Fixes tests for #926 and #2537
#4750 Reduce the number of resources loaded by GetDoc
Attached patch Update pdf.js to version 1.0.159 (obsolete) — Splinter Review
r?Mossop on the PdfStreamConverter.jsm change, r?yury on the rest.
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #8419359 - Flags: review?(ydelendik)
Attachment #8419359 - Flags: review?(dtownsend+bugmail)
Attachment #8419359 - Flags: review?(dtownsend+bugmail) → review+
Summary: Update pdf.js to version 1.0.159 → Update pdf.js to version 1.0.162
Changes since the last version:
#4756 Add getFindBar for Fx extension (refactor)
#4753 Add getFindBar for Fx extension
Attachment #8419359 - Attachment is obsolete: true
Attachment #8419359 - Flags: review?(ydelendik)
Attachment #8419516 - Flags: review?(ydelendik)
Blocks: 1006714
Comment on attachment 8419516 [details] [diff] [review]
Update pdf.js to version 1.0.162

Dave, not sure if you want to look at the new PdfStreamConverter.jsm changes.
Attachment #8419516 - Flags: review?(dtownsend+bugmail)
Attachment #8419516 - Flags: review?(ydelendik) → review+
Attachment #8419516 - Flags: review?(dtownsend+bugmail) → review+
https://hg.mozilla.org/integration/fx-team/rev/970b90975e1c
Flags: in-testsuite+
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/970b90975e1c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 32
Blocks: 1000777
Blocks: 1016308
Depends on: 1020226
Blocks: 1026488
Blocks: 1007117
Depends on: 1072164
You need to log in before you can comment on or make changes to this bug.