Closed Bug 1027068 Opened 8 years ago Closed 8 years ago

Marketplace header still doesn't move with page when in overscroll

Categories

(Core :: Panning and Zooming, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: cwiiis, Unassigned)

References

Details

Even after landing bug 1019996, the header of the marketplace still stays at the top of the screen and compresses into the top-left during overscroll.

Perhaps the layer configuration of the marketplace is circumventing the newly added code - Bug 950993 may be useful for reference here.

Possibly related, the music app in overscroll compresses towards the left edge instead of towards the center.

Nominating as a 2.0 blocker as this is part of the overscroll work and exhibits a visible bug in common apps.
Blocks: 1019996
Strange, I can't reproduce this on a Nexus 4 with today's trunk.

It's possible that a difference in layerization (for whatever reason) is causing a difference in behaviour. It would be helpful to see a layer dump for a page that reproduces the issue.
Ugh, I was building from the wrong tree, sorry for the waste of time. This feature works fine, good job :)

The music player song list still compresses to one side, but this is a separate bug and I'll file that.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.