Modify telephony API from dialEmergency(number, serviceId) to dialEmergency(number)

RESOLVED FIXED in 2.0 S6 (18july)

Status

Firefox OS
RIL
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aknow, Assigned: rik)

Tracking

unspecified
2.0 S6 (18july)
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
We don't need to specify the serviceId. Gecko could automatically choose the proper one for the request.
(Reporter)

Updated

4 years ago
Depends on: 1031239
(Reporter)

Comment 1

4 years ago
In order to land the change smoothly, I suggest to separate it into 3 stages:

1. Gecko automatically select the sim card when dialing emergency call. 
   No interface change. The provided serviceId will be overwritten by gecko's choice.
   => Bug 1031239

2. Gaia modifies the usage of api. Ignore the argument of serviceId. Since this parameter is an optional field. It will not break the interface. Also, the behavior should be the same as stage 1.

3. Gecko modifies the interface. Remove parameter |serviceId|
   => this bug
(Reporter)

Comment 2

4 years ago
Hi Anthony,

Step 1 is landed. It's time for gaia to remove the usage of 2nd parameter in dialEmergency(number, serviceId)
Flags: needinfo?(anthony)
(Assignee)

Comment 3

4 years ago
Created attachment 8458741 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/21935
Assignee: szchen → anthony
Status: NEW → ASSIGNED
Attachment #8458741 - Flags: review?(drs+bugzilla)
Flags: needinfo?(anthony)
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.0 S6 (18july)
Comment on attachment 8458741 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/21935

I left one comment on the PR for a removal that I think was accidental.
Attachment #8458741 - Flags: review?(drs+bugzilla) → review+
(Assignee)

Comment 5

4 years ago
Doh! Good catch!

https://github.com/mozilla-b2g/gaia/commit/3c56d1983f46d1d9dce509cdce02e207bce0df29
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 926345
Duplicate of this bug: 930866
You need to log in before you can comment on or make changes to this bug.