Closed Bug 1027516 Opened 7 years ago Closed 7 years ago

navigator.getMobileIdAssertion() does not call error handler when offline

Categories

(Core :: DOM: Device Interfaces, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: freddy, Assigned: ferjm)

References

Details

When offline (no data, no wifi available), I get no (error) response to the promise in userland JavaScript.

adb logcat gives me:
I/Gecko   (  291): 1403162013651	MobileId	ERROR	getMobileIdAssertion rejected with OFFLINE
I/Gecko   (  291): 1403162013651	MobileId	ERROR	UI error OFFLINE
Works for me.

Gecko  I  1402650573170	MobileId	ERROR	getMobileIdAssertion rejected with OFFLINE
Gecko  I  1402650573177	MobileId	ERROR	UI error OFFLINE
Gecko  I  1402650573179	MobileId	DEBUG	Received message MobileId:GetAssertion:Return:KO: {"promiseId":"id{8960eb3d-7092-4660-b6e0-4f48e6e39f1b}","error":"OFFLINE"}
GeckoConsole  E  Content JS ERROR at app://mobileidtest.gaiamobile.org/js/app.js:53 in App.onError: ERROR OFFLINE

Can you check again and reopen if you can still reproduce it, please? Thanks!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.