[User story] Transfer ringtones from SD card to ringtones folder

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: skasetti, Assigned: squib)

Tracking

unspecified
2.1 S3 (29aug)
ARM
Gonk (Firefox OS)
Bug Flags:
in-testsuite +
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.1, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: interaction-design [2.1-feature-qa+])

User Story

As a user, I want to transfer my ringtones on my SD card (ringtones used on android phone) to my firefox OS device

Attachments

(2 attachments)

Comment hidden (empty)
Whiteboard: interaction-design
Jim - I think during the planning meeting a couple weeks ago you said you would come up with the edge cases and send them out?
Flags: needinfo?(squibblyflabbetydoo)
Flags: in-moztrap?(mozillamarcia.knous)

Updated

4 years ago
Assignee: nobody → squibblyflabbetydoo
(Assignee)

Comment 2

4 years ago
Here are all the edge cases I can think of:

* What happens when the SD card is removed? (If it's like the music app, I think we'd treat that as all the ringtones being deleted.)

* Scanning for new ringtones will probably be somewhat slower than the other methods, so maybe we want a loading throbber. (Probably best to wait until we have numbers, though.)

* Should we try to parse the metadata for files? That seems like an awful lot of code to import for something so simple. Maybe we can just use the filenames.

* Should deleting an SD card ringtone from within the ringtones app delete the actual file? (Probably.)

* Do we want separate folders for Ringtones and Notifications? What does Android do here?
Flags: needinfo?(squibblyflabbetydoo)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1037881
(Assignee)

Comment 4

4 years ago
Tif, two things I realized while implementing this:

1) Should ringtones from the SD card go into the "Custom Ringtones" section, or should they get a new section (e.g. "SD Card Ringtones")?

2) It looks like Android has 3 folders to put sounds in: /Ringtones, /Notifications, and /Alerts. I don't think we need to handle alerts just yet, but if we want to support custom notifications (and I think we should), we probably want to add a new section: "Custom Notifications". However, we don't currently show notifications in the "Manage Ringtones" view. What should we do here?
Flags: needinfo?(tshakespeare)

Updated

4 years ago
Flags: needinfo?(tshakespeare) → needinfo?(kcaldwell)

Updated

4 years ago
QA Whiteboard: [2.1-feature-qa+]
(Assignee)

Comment 5

4 years ago
(In reply to Jim Porter (:squib) from comment #4)
> 2) It looks like Android has 3 folders to put sounds in: /Ringtones,
> /Notifications, and /Alerts. I don't think we need to handle alerts just

Oops, I mean "alarms", not "alerts".

Comment 6

4 years ago
Now, if the user transfers these files to these folders, will that then make the Music app skip indexing them and adding them to the Music list?

That is the reason I suggested having the Music app & System recognize the "ringtone/ringtones" metadata tag in my bug.
(Assignee)

Comment 7

4 years ago
Yes, part of this bug will involve making the music app skip anything in the aforementioned folders.

Comment 8

4 years ago
(In reply to Jim Porter (:squib) from comment #7)
> Yes, part of this bug will involve making the music app skip anything in the
> aforementioned folders.

Wonderful :) Thanks!
(Reporter)

Comment 9

4 years ago
> 2) It looks like Android has 3 folders to put sounds in: /Ringtones,
> /Notifications, and /Alerts. I don't think we need to handle alerts just
> yet, but if we want to support custom notifications (and I think we should),
> we probably want to add a new section: "Custom Notifications". However, we
> don't currently show notifications in the "Manage Ringtones" view. What
> should we do here?

In 2.1 let's add just the ringtones. 
Jim, can you file bugs for notifications and alerts?
(Assignee)

Comment 10

4 years ago
(In reply to Sri Kasetti from comment #9)
> In 2.1 let's add just the ringtones. 
> Jim, can you file bugs for notifications and alerts?

I disagree pretty strongly with this. Aside from thinking a bit about UI, it's almost no extra work to support notifications[1]. I really don't think we should defer useful and easy-to-implement features just because we don't want to think about how to present them. To be honest, I think we should have supported managing notifications back in *2.0* (read: showing the built-in notifications in the "Manage ringtones" list so that people could share them).

There are a couple of easy ways to show custom notifications:
1) Just add a "Custom Notifications" category and insert it where appropriate.
2) Add "Ringtones" and "Notifications" tabs to the ringtones app so that you can switch between them. Picking a ringtone would default to showing the ringtones tab; likewise for picking a notification.

[1] Alarms would be a 2.2 feature though, since I don't think Clock is ready to talk to the Ringtones app for sound files.
(Reporter)

Comment 11

4 years ago
Katie, can you take a look at Jim's suggestion for notifications?
It looks like we could do this easily in 2.1
Can you take a look at how the notifications flow would work?

Comment 12

4 years ago
(In reply to Jim Porter (:squib) from comment #4)
 
> 1) Should ringtones from the SD card go into the "Custom Ringtones" section,
> or should they get a new section (e.g. "SD Card Ringtones")?

Ringtones from SD card should go into the "Custom Ringtones" section, but let's rename the section "My Ringtones". There are then 2 distinct categories of ringtones: FF system ringtones (uneditable, but shareable) and My ringtones (from music, downloads, sd card and editable[2.2] and shareable)
> 
> 2) It looks like Android has 3 folders to put sounds in: /Ringtones,
> /Notifications, and /Alerts. I don't think we need to handle alerts just
> yet, but if we want to support custom notifications (and I think we should),
> we probably want to add a new section: "Custom Notifications". However, we
> don't currently show notifications in the "Manage Ringtones" view. What
> should we do here?

For 2.1 I'd recommend adding "Manage Alerts" (enables sharing and "+" adding custom alerts) below "Manage Ringtones" as they are separate concepts to the user. For 2.2, we can revisit "Manage Sounds" and it's subset of Ringtones/Alerts/Alarms.

Updated

4 years ago
Flags: needinfo?(kcaldwell)
(Assignee)

Comment 13

4 years ago
Created attachment 8468872 [details] [review]
Do the thing that this bug says

Here's a WIP patch to do this. It's pretty basic and mainly just serves as a checkpoint of my work for now.

Updated

4 years ago
QA Contact: mozillamarcia.knous

Updated

4 years ago
QA Whiteboard: [2.1-feature-qa+]
Whiteboard: interaction-design → interaction-design [2.1-feature-qa+]

Updated

4 years ago
Flags: in-moztrap?(mozillamarcia.knous) → in-moztrap?
QA Contact: mozillamarcia.knous

Updated

4 years ago
QA Contact: npark
Target Milestone: --- → 2.1 S2 (15aug)
Hema - My understanding from talking with Tony was that No-Jun would be assisting with other media areas, but not ringtones. Alison will be assisting with testing of ringtone features.
Flags: needinfo?(hkoka)

Comment 15

4 years ago
(In reply to Jason Smith [:jsmith] from comment #14)
> Hema - My understanding from talking with Tony was that No-Jun would be
> assisting with other media areas, but not ringtones. Alison will be
> assisting with testing of ringtone features.

Okay, I didn't know that. Can you please add Alison as the QA contact.

Thanks
Hema
Flags: needinfo?(hkoka) → needinfo?(jsmith)
Sure.
Flags: needinfo?(jsmith)
Flags: in-moztrap?(ashiue)
Flags: in-moztrap?
QA Contact: npark → ashiue

Updated

4 years ago
QA Whiteboard: [COM=Ringtones]

Updated

4 years ago
QA Whiteboard: [COM=Ringtones] → [COM=Gaia::Ringtones]
(Assignee)

Comment 17

4 years ago
(In reply to katieC from comment #12)
> For 2.1 I'd recommend adding "Manage Alerts" (enables sharing and "+" adding
> custom alerts) below "Manage Ringtones" as they are separate concepts to the
> user. For 2.2, we can revisit "Manage Sounds" and it's subset of
> Ringtones/Alerts/Alarms.

I'm not sure we want to let users add custom alerts via the "+" just yet. Most song files will be way too long, and we end up cutting off all but the first second or two of the audio, which means that a lot of songs-turned-into-alerts would actually be totally silent!

Just for the purposes of having something to play with, I put all the ringtones and alert tones into the same list under "Manage Ringtones" (they're in different sections, though). Feel free to flash a device with my build to try it out. You'll probably need to run `reset-gaia` though, since my build changes the Ringtone app's permissions.
(Assignee)

Comment 18

4 years ago
Oh, and I should note that I'm assuming we're still going to reset the user's default ringer/alert sound for 2.1. Doing so gives me the opportunity to make this code a bit saner.

Comment 19

4 years ago
(In reply to Jim Porter (:squib) from comment #17)
> I'm not sure we want to let users add custom alerts via the "+" just yet.
> Most song files will be way too long, and we end up cutting off all but the
> first second or two of the audio, which means that a lot of
> songs-turned-into-alerts would actually be totally silent!

Agree. That would be very frustrating. The only option available to the user then is Share (and Delete if they've got their own alerts transferred from their SD Card).

> 
> Just for the purposes of having something to play with, I put all the
> ringtones and alert tones into the same list under "Manage Ringtones"
> (they're in different sections, though). Feel free to flash a device with my
> build to try it out. You'll probably need to run `reset-gaia` though, since
> my build changes the Ringtone app's permissions.

Worked for me. 

Jim: If I had created a folder called "Alerts" (instead of "Notifications") on my SD Card, would the Manager have recognized this folder and populated "My Alerts"? If we are using the label "Alerts" in Settings » Sound to also mean "Notifications", then we should support both folder names.
(Assignee)

Comment 20

4 years ago
(In reply to katieC from comment #19)
> Jim: If I had created a folder called "Alerts" (instead of "Notifications")
> on my SD Card, would the Manager have recognized this folder and populated
> "My Alerts"? If we are using the label "Alerts" in Settings » Sound to also
> mean "Notifications", then we should support both folder names.

I suppose that's possible, but I was mainly following along with how Android organizes things. "Alerts" might be too easy to confuse with "Alarms", too...

Comment 21

4 years ago
Hi Jim and Katie,

May I clarify the spec for this user story?

1. If user select a song from SD card as ringtone, what happens when the SD card is undetected(removed/formatted/ejected)?
   - Back to default ringtone(Firefox OS)?
2. Continue Q1, what if SD card insert back? is the selected song at Q1 be the ringtone again?
(I tried Sony XPERIA with Android 4.0.4, in Q2, ringtone will become the SD card's song which selected at Q1 automatically)
3. Is folder name case sensitive (/Ringtones, /Notifications, and /Alerts) in SD card? Do we support the three folders in this user story? 
4. We will have "Firefox Ringtones", "Custom Ringtones", and "My Ringtones" at "Manage Ringtones"
5. We will have "Manage Alerts" just like "Manage Ringtones"

Thanks!
(Assignee)

Comment 22

4 years ago
1. Nothing happens. The ringtone the user picked is still played (because the system has its own copy of it).

2. Nothing happens. See (1).

3. The folder names are either case-sensitive or case-insensitive depending on the filesystem you chose for the SD card, but that's usually FAT32, so it's case-insensitive in that case.

4. Just "Firefox Ringtones" and "My Ringtones".

5. No. We'll have "Manage Tones", which will let the user manage ringtones and alert tones.

Comment 23

4 years ago
Thanks, Jim.

(In reply to Jim Porter (:squib) from comment #22)
> 5. No. We'll have "Manage Tones", which will let the user manage ringtones
> and alert tones.
So we will have "Manage Tones" in Manage Sounds section, and go into "Manage Tones" will list "Firefox Ringtones", "My Ringtones", "Firefox Alerts", and "My Alerts", right?

Comment 24

4 years ago
Sorry, more questions:
(1) Do we store copies of all ringtones or notifications in SD card, even ones that aren't currently set as the default ringer or alert?
(2) In this user story, we only use /Ringtones and /Notifications in SD card to get ringtones and alerts?

Comment 25

4 years ago
Do we have UX doc for this user story?
Adding needinfo to UX to look into the questions mentioned in the above comments.
Flags: needinfo?(kcaldwell)
(Assignee)

Comment 27

4 years ago
(In reply to ashiue from comment #23)
> So we will have "Manage Tones" in Manage Sounds section, and go into "Manage
> Tones" will list "Firefox Ringtones", "My Ringtones", "Firefox Alerts", and
> "My Alerts", right?

Yes. The "My _____" categories will only show up if there are items in those categories, though.

(In reply to ashiue from comment #24)
> (1) Do we store copies of all ringtones or notifications in SD card, even
> ones that aren't currently set as the default ringer or alert?

No. Only the currently-selected ones. This is because of how web activities are structured in Firefox OS; they're very loosely-coupled, and so copying the sound file when you set it is the safest way to store it. I'm open to other options, but that would be a significant architectural change.

> (2) In this user story, we only use /Ringtones and /Notifications in SD card
> to get ringtones and alerts?

Yes. Katie suggested also getting alerts from /Alerts, but I don't think we should do that, since I really think it makes more sense to have a single canonical place to store the files. We use /Notifications for compatibility with Android.

(In reply to ashiue from comment #25)
> Do we have UX doc for this user story?

I don't think it has the latest changes that Katie and I agreed on, but: https://github.com/mozilla-b2g/gaia-specs/blob/master/%5B2.1%5D%20Ringtones%20TransferSDCard.pdf

Comment 28

4 years ago
Katie, QA is having trouble finding specs for this that reflect all changes. Can you please attach, link to or confirm that the link in the comment above is accurate? Thanks!

Comment 29

4 years ago
(In reply to Stephany Wilkes from comment #28)
> Katie, QA is having trouble finding specs for this that reflect all changes.
> Can you please attach, link to or confirm that the link in the comment above
> is accurate? Thanks!

link is accurate. Just updated with new updates:
Spec [2.1] Ringtones Transfer SDCard.pdf can be found here: 
https://github.com/mozilla-b2g/gaia-specs/blob/master/%5B2.1%5D%20Ringtones%20TransferSDCard.pdf
Flags: needinfo?(kcaldwell)

Comment 30

4 years ago
Updated UX spec: as of 2:19pm PST - please see link above
(minor update to spec: removal of confirmation banner)
(Assignee)

Comment 31

4 years ago
Comment on attachment 8468872 [details] [review]
Do the thing that this bug says

David: Could you take a quick look at this to make sure it's sane?

Dominic: Since David will be out next week, and he's already pretty busy, I'll probably be asking you to review this. It's not quite done yet, since I haven't written tests, but I think the code is pretty stable.

Katie: Could you look over this to make sure I got the UX right?
Attachment #8468872 - Flags: ui-review?(kcaldwell)
Attachment #8468872 - Flags: feedback?(dkuo)
Attachment #8468872 - Flags: feedback?(dflanagan)

Comment 32

4 years ago
Spec update 2:32pm PST - sorry, very minor changes(pages reorders, date updated, version updated) see link above for access to spec on github.
(Assignee)

Comment 33

4 years ago
Oh, one thing I forgot to do: hide the ringtones from the music app!
(Assignee)

Comment 35

4 years ago
Comment on attachment 8468872 [details] [review]
Do the thing that this bug says

Dave: In the marionette tests, I keep getting a TypeMismatchError from device storage. Do you know what could be causing this?
Attachment #8468872 - Flags: feedback?(dhylands)

Comment 36

4 years ago
Comment on attachment 8468872 [details] [review]
Do the thing that this bug says

Jim, I quickly pulled and tested your wip on my flame, and the implementation did followed the spec and works fine, though I didn't check the code in detail, but just keep working on it and feel free to request review from me if needed, thanks :)
Attachment #8468872 - Flags: feedback?(dkuo) → feedback+
(In reply to Jim Porter (:squib) from comment #35)
> Comment on attachment 8468872 [details] [review]
> Do the thing that this bug says
> 
> Dave: In the marionette tests, I keep getting a TypeMismatchError from
> device storage. Do you know what could be causing this?

Can you point me at the test that's failing?
I need to figure out the name of the file that's causing the TypeMismtachError and the storageType being used.
Flags: needinfo?(squibblyflabbetydoo)
Flags: needinfo?(squibblyflabbetydoo)
Comment on attachment 8468872 [details] [review]
Do the thing that this bug says

Jim,

I took a quick look, focusing mainly on the sdcard code, and overall it looks good.

I'm concerned about the regexp you're using in the music app, but maybe just because I don't understand it sufficiently.

My main comments are localization issues, including mainly that the l10n team doesn't want you to use get() anymore.

See github for details.
Attachment #8468872 - Flags: feedback?(dflanagan) → feedback+

Comment 39

4 years ago
Given we're in sprint 3 now, can we update the target milestone? If we're comfortable to land this by this month, please change the target milestone to sprint 3. Otherwise, please highlight it, and we should come out some mitigation plans. Thank you.
Flags: needinfo?(squibblyflabbetydoo)
(Assignee)

Comment 40

4 years ago
I think I mentioned this in an email already, but for the sake of completeness: this bug is 99% done, and I'm just trying to fix some broken tests. Assuming reviews go reasonably quickly, this should land in a couple days.
Flags: needinfo?(squibblyflabbetydoo)
Target Milestone: 2.1 S2 (15aug) → 2.1 S3 (29aug)

Comment 41

4 years ago
(In reply to Jim Porter (:squib) from comment #40)
> I think I mentioned this in an email already, but for the sake of
> completeness: this bug is 99% done, and I'm just trying to fix some broken
> tests. Assuming reviews go reasonably quickly, this should land in a couple
> days.

Awesome! Thank you very much! Jim.
(Assignee)

Comment 42

4 years ago
Comment on attachment 8468872 [details] [review]
Do the thing that this bug says

Dominic: This isn't *quite* done, since I still want to add a few more tests, but existing tests all pass and the actual code should be ready for a full review. Thanks!
Attachment #8468872 - Flags: review?(dkuo)
(Assignee)

Updated

4 years ago
Attachment #8468872 - Flags: feedback?(dhylands)
(Assignee)

Comment 43

4 years ago
Also Dominic: if you could review this soon, that would be great. Sorry for such short notice, but folks want this to land by Wednesday (which, realistically, probably won't happen).

Comment 44

4 years ago
(In reply to Jim Porter (:squib) from comment #43)
> Also Dominic: if you could review this soon, that would be great. Sorry for
> such short notice, but folks want this to land by Wednesday (which,
> realistically, probably won't happen).

I am reviewing it and hope I can finish it before my Wednesday then we could land it by your Wednesday.

Comment 45

4 years ago
Comment on attachment 8468872 [details] [review]
Do the thing that this bug says

Jim, the patch looks good to me, also I have tested on my flame and it works pretty well, and the tests passed.

It's probably that I am not familiar with the ux of managing ringtones, I have found a flow which seems not straightforward to me(not the changes we made in this bug), it's: Settings > Sound > Manage Ringtones > Press the "+" button > Music picker > Select one song > Press done button > Create ringtone > Press Save > Back to Manage Ringtones. The "Create ringtone" step seems not so necessary, but if it's expected and as design, please ignore this, just want to confirm it, thanks!
Attachment #8468872 - Flags: review?(dkuo) → review+

Comment 46

4 years ago
Dominic, to your UX questions I've set ni? to Katie, who knows the UX here. Please feel free to set ui-review? to her for anything you might need on patches. Thanks!
Flags: needinfo?(kcaldwell)
(Assignee)

Comment 47

4 years ago
(In reply to Dominic Kuo [:dkuo] from comment #45)
> It's probably that I am not familiar with the ux of managing ringtones, I
> have found a flow which seems not straightforward to me(not the changes we
> made in this bug), it's: Settings > Sound > Manage Ringtones > Press the "+"
> button > Music picker > Select one song > Press done button > Create
> ringtone > Press Save > Back to Manage Ringtones. The "Create ringtone" step
> seems not so necessary, but if it's expected and as design, please ignore
> this, just want to confirm it, thanks!

Yeah, that's expected, but not really the best UX. It'll make a lot more sense when we can crop ringtones, since the "Create ringtone" step will have a lot more in it.

Comment 48

4 years ago
Yes, as Jim said, when we get into Creating/cropping ringtones for 2.2 the UX will be reviewed and address comment 45 concerns.
Flags: needinfo?(kcaldwell)

Comment 49

4 years ago
Comment on attachment 8468872 [details] [review]
Do the thing that this bug says

UI+ ...in the interest of not holding up FL

but, there is follow up on Removal of SD Card and continuing to display the assigned default copy of a (no longer present) SD Card ringtone.
Attachment #8468872 - Flags: ui-review?(kcaldwell) → ui-review+
(Assignee)

Comment 50

4 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/48db751348f803c19fc3934ea746e5211aeb85ef
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Sorry to reopen but this is never going to work.

https://github.com/mozilla-b2g/gaia/blob/48db751348f803c19fc3934ea746e5211aeb85ef/shared/locales/branding/official/branding.en-US.properties
You put localizable items in /branding, but /branding is not localized for official builds.

This means that, on official builds, people will see "Firefox Ringtones" and "Firefox Alers", which is not acceptable.

This bug either needs a backout or a quick fix given the tight schedule. Personally I'd be for a backout for now.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 52

4 years ago
Wait, a backout instead of a one-line fix? Seriously? All I need is some advice on how you'd like me to ensure that things are grammatically correct for other locales and I can land something.
I said "either a backup or a quick fix", the important thing is not let slip this into 2.1 ;-)

The problem is: strings in /branding will always be taken from en-US. That prevents us from shipping phones with official branding and something different from "Firefox" or "Firefox OS".

So, the solution is to move those strings somewhere where localization is effective.
(Assignee)

Comment 54

4 years ago
Created attachment 8481455 [details] [review]
L10N followup
(Assignee)

Comment 55

4 years ago
Comment on attachment 8481455 [details] [review]
L10N followup

r+ from justindarc via IRC.
Attachment #8481455 - Flags: review+
(Assignee)

Comment 56

4 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/5fd348dc8c313517d2b45529ff9c62d85f69a54d
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
This landing caused perma-red marionette failures. I've fixed the failures and re-landed with the fix squashed into your commit.

Revert: https://github.com/mozilla-b2g/gaia/commit/842202c2fbd084514cc72ff256d7f4b4e3c2b210
Re-landed (:squib as author): https://github.com/mozilla-b2g/gaia/commit/ae42e2ced7a0766e2ff4a1ef8b6c3fa5c9fe2eba

Comment 58

4 years ago
Verified landed
Gaia      2be78d83a760fa3b9638fe51c266b442d14597f1
Gecko     https://hg.mozilla.org/mozilla-central/rev/1db35d2c9a2f
BuildID   20140831160203
Version   34.0a1
Status: RESOLVED → VERIFIED

Updated

4 years ago
QA Whiteboard: [COM=Gaia::Ringtones] → [QAnalyst-Triage?], [COM=Gaia::Calendar]
status-firefox34: --- → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?], [COM=Gaia::Calendar] → [QAnalyst-Triage+], [COM=Gaia::Calendar]
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+], [COM=Gaia::Calendar] → [QAnalyst-Triage+], [COM=Gaia::Ringtones]
This issue is verified fixed on Flame 2.1(319mb)

Environmental Variables:
Device: Flame Master
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

User is able to transfer ringtones from SD card to ringtones folder.
QA Whiteboard: [QAnalyst-Triage+], [COM=Gaia::Ringtones] → [QAnalyst-Triage?], [COM=Gaia::Ringtones]
Flags: needinfo?(ktucker)
Please verify that this is working as intended according to this pdf file:///C:/Users/Root/Downloads/[2.1]%20Ringtones%20TransferSDCard.pdf
QA Whiteboard: [QAnalyst-Triage?], [COM=Gaia::Ringtones] → [QAnalyst-Triage-], [COM=Gaia::Ringtones]
Flags: needinfo?(ktucker) → needinfo?(jthomas)
This issue is verified fixed on Flame 2.1(319mb) and is working as intended according PDF doc - tohttps://github.com/mozilla-b2g/gaia-specs/blob/master/%5B2.1%5D%20Ringtones%20TransferSDCard.pdf

Flame 2.1(319mb)

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

STR:
1: Insert an SD card with a custom ringtone installed on it.
2: Turn on device and launch Settings
3: Select Tones
4: Select Manage Tones
5. Scroll down to My Ringtones.

Actual Result: Custom ringtone has been transferred to ringtones folder.
QA Whiteboard: [QAnalyst-Triage-], [COM=Gaia::Ringtones] → [QAnalyst-Triage?], [COM=Gaia::Ringtones]
Flags: needinfo?(jthomas) → needinfo?(ktucker)

Comment 62

4 years ago
To elaborate on comment 61:

The device reflects the behavior listed in https://github.com/mozilla-b2g/gaia-specs/blob/master/%5B2.1%5D%20Ringtones%20TransferSDCard.pdf
except for 2 issues.

Issue #1:

Expected:
The source of the ringtone is listed in Manage Ringtones (SD card/ Internal)

Actual:
The source of the ringtone is not listed.

Issue #2

Expected:
After removing the SD card that contains the custom ringtones, only the default ringtone will appear and will disappear once selecting another ringtone.

Actual:
All ringtones created with music found on the SD card are visible and can be set before and after selecting another ringtone. Once selected, The ringtone displays as "saving ringtone" and never updates. When receiving a call, one of the pre-installed sounds play. The songs are not found in Music.

Flame 2.1(319mb)

Environmental Variables:
Device: Flame Master (319mb)
BuildID: 20140902040205
Gaia: 44bf2e3bc5ddea9db9a8c851bd353cb234aa883c
Gecko: c360f3d1c00d
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Updated

4 years ago
Depends on: 1063236

Updated

4 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 4 years ago4 years ago
No longer depends on: 1063236

Updated

4 years ago
Depends on: 1063236
(Assignee)

Updated

4 years ago
No longer depends on: 1063236

Updated

4 years ago
Depends on: 1063654

Comment 63

4 years ago
Unable to verify due to bug 1063236 and bug 1063654 which have been created to address the two issues listed in comment 62

Updated

4 years ago
No longer depends on: 1063654

Comment 64

4 years ago
Verified:
I am able to add audio files to a SD card and then view on the device.
Status: RESOLVED → VERIFIED

Comment 65

4 years ago
Verified landed for 2.1 and 2.2

Actual Result:
I am able to add audio files to a SD card and then view on the device.

Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)
BuildID: 20140905040204
Gaia: 5765c62163bcb7fde5ebfd211881117de31a7c46
Gecko: dddbe46f3ceb
Version: 35.0a1 (2.2 Master)
Firmware: V123
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.1

Environmental Variables:
Device: Flame 2.1 (319mb)
Build ID: 20140905000202
Gaia: 95e9b099aa89ded133e44014dd40b19dc0193c01
Gecko: 92a6bbdfd945
Version: 34.0a2
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
status-b2g-v2.1: --- → verified
status-b2g-v2.2: --- → verified
status-firefox34: verified → ---
QA Whiteboard: [QAnalyst-Triage?], [COM=Gaia::Ringtones] → [QAnalyst-Triage+], [COM=Gaia::Ringtones]
Flags: needinfo?(ktucker)
+section-title-builtin-ringtone = {{ringtoneSectionBrandName}} Ringtones
+section-title-builtin-alerttone = {{ringtoneSectionBrandName}} Alerts

This will not work for Polish - I'm dropping both {{ringtoneSectionBrandName}} variables in polish l10n.
(Assignee)

Comment 67

4 years ago
(In reply to Stefan Plewako [:stef] from comment #66)
> +section-title-builtin-ringtone = {{ringtoneSectionBrandName}} Ringtones
> +section-title-builtin-alerttone = {{ringtoneSectionBrandName}} Alerts
> 
> This will not work for Polish - I'm dropping both
> {{ringtoneSectionBrandName}} variables in polish l10n.

Can you elaborate? I imagine the goal here is to optimize for grammar in "Firefox Ringtones" and "Firefox Alerts", so you don't need this to be grammatically correct in general. While that would make things worse for non-branded builds (which use "System Ringtones" and "System Alerts"), I don't think we need to worry about that case all that much, since we're not shipping unbranded devices.
(In reply to Jim Porter (:squib) from comment #67)
In order to use nominative with ringtoneSectionBrandName I would need a helper word (ie app, [operating] system) which seems impossible with current implementation, so I translated them as "system ringtones|alerts".
(In reply to Stefan Plewako [:stef] from comment #68)
> In order to use nominative with ringtoneSectionBrandName I would need a
> helper word (ie app, [operating] system) which seems impossible with current
> implementation, so I translated them as "system ringtones|alerts".

I'm not sure I follow. Why can't you change ringtoneSectionBrandName to the correct case? It's used only for these 2 strings.
(In reply to Francesco Lodolo [:flod] from comment #69)
> I'm not sure I follow. Why can't you change ringtoneSectionBrandName to the
> correct case? It's used only for these 2 strings.

It lives in unlocalizable file (official branding)?
(In reply to Stefan Plewako [:stef] from comment #70)
> It lives in unlocalizable file (official branding)?

You're absolutely right :-\

One more question: the strings are 
* Firefox Ringtones
* Firefox Alerts
* System Ringtones
* System Alerts

How would you translate them in Polish?
(In reply to Francesco Lodolo [:flod] from comment #71)
> One more question: the strings are 
> * Firefox Ringtones
> * Firefox Alerts
> * System Ringtones
> * System Alerts
> 
> How would you translate them in Polish?

* Dzwonki Firefoksa
* Alarmy Firefoksa
* Dzwonki systemowe
* Alarmy systemowe

With generic "Firefox" as brand, with more meaningful brand (like os name) other constructs may be possible.
You need to log in before you can comment on or make changes to this bug.