Right click menu dimensions breaks after Simulate touch events on secondary monitor

RESOLVED FIXED in Firefox 52

Status

RESOLVED FIXED
5 years ago
6 months ago

People

(Reporter: enotramone, Unassigned)

Tracking

30 Branch
Firefox 52
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8443335 [details]
Step 5 - pop-up menu with broken dimensions

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.131 YaBrowser/14.5.1847.18375 Safari/537.36

Steps to reproduce:

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0

Steps to reproduce:

1. Open browser on a secondary monitor;
2. Open Developer Tools in Responsive Design Mode (if we right click on a content area - а normal pop-up menu will shown on the expected place of the pointer);
3. Enable Simulate touch events, Reload the page;
4. LEFT click and hold on a content area - pop-up menu will shown, but on another (main) monitor;
5. Now RIGRHT click on a content area - pop-up menu will shown, but with broken dimensions.

Reproduces with any web site.

The only way to "repair" the menu is to reload the browser.


Actual results:

Pop-up menu by right click has broken dimensions after using Simulate touch events in Responsive Design Mode.


Expected results:

1. Dimensions of pop-up menu shouldn't change.
2. During usage Simulate touch events in Responsive Design Mode, when you left click and hold on a content area, the pop-up menu must open on a secondary monitor (the monitor, where browser actually runs).

Updated

5 years ago
Duplicate of this bug: 1028075

Updated

5 years ago
Duplicate of this bug: 1028078

Updated

5 years ago
Component: Untriaged → Developer Tools: Responsive Mode
(Reporter)

Updated

5 years ago
Summary: Right click menu dimensions breaks after Simulate touch events on secondary monitor → Right click menu dimensions break after Simulate touch events on secondary monitor
(Reporter)

Updated

5 years ago
Summary: Right click menu dimensions break after Simulate touch events on secondary monitor → Right click menu dimensions breaks after Simulate touch events on secondary monitor
This bug appears to be fixed in the new RDM UI shipping in Firefox 52.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Depends on: 1305769
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.