Closed Bug 1028081 Opened 6 years ago Closed 6 years ago

error: allocating an object of abstract class type 'mozilla::mailnews::MsgDBReporter'

Categories

(MailNews Core :: Database, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1028217

People

(Reporter: ewong, Assigned: ewong)

Details

Attachments

(1 file, 1 obsolete file)

Bug 1010064 changed the # of required parameters to MsgDBReporter.


   NS_IMETHOD CollectReports(nsIHandleReportCallback* aHandleReport,
-                            nsISupports* aData)
+                            nsISupports* aData, bool aAnonymize)

Neil, over irc, mentioned that adding the extra parameter would fix this.
Attached patch bug fix patch (v1) (obsolete) — Splinter Review
Attached patch fixed nit (v2)Splinter Review
Assignee: nobody → ewong
Attachment #8443361 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1028217
You need to log in before you can comment on or make changes to this bug.