Closed Bug 1028217 Opened 6 years ago Closed 6 years ago

Update CollectReports() to fix c-c bustage caused by Bug 1010064

Categories

(MailNews Core :: Backend, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 33.0

People

(Reporter: philip.chee, Assigned: philip.chee)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=42134034&tree=Thunderbird-Trunk#error0

c:/builds/moz2_slave/tb-c-cen-w32-ntly-000000000000/build/objdir-tb/mozilla/_virtualenv/Scripts/python.exe -m mozbuild.action.buildlist ../../../mozilla/dist/bin/chrome.manifest "manifest components/offlineStartup.manifest"
nsMsgDatabase.cpp
c:/builds/moz2_slave/tb-c-cen-w32-ntly-000000000000/build/mailnews/db/msgdb/src/nsMsgDatabase.cpp(1125) : error C2259: 'mozilla::mailnews::MsgDBReporter' : cannot instantiate abstract class
        due to following members:
        'nsresult nsIMemoryReporter::CollectReports(nsIMemoryReporterCallback *,nsISupports *,bool)' : is abstract
        c:\builds\moz2_slave\tb-c-cen-w32-ntly-000000000000\build\objdir-tb\mozilla\dist\include\nsIMemoryReporter.h(113) : see declaration of 'nsIMemoryReporter::CollectReports'
Attached patch Patch v1.0 One line fix. (obsolete) — Splinter Review
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8443477 - Flags: review?(standard8)
Comment on attachment 8443477 [details] [diff] [review]
Patch v1.0 One line fix.

I think we need to anonymize the path here. Using something like "<anonymized>" as per the original patch seems the right thing to do.
Attachment #8443477 - Flags: review?(standard8) → review-
(In reply to Mark Banner (:standard8) from comment #2)
> I think we need to anonymize the path here. Using something like
> "<anonymized>" as per the original patch seems the right thing to do.
Fixed.
Attachment #8443477 - Attachment is obsolete: true
Attachment #8443523 - Flags: review?(standard8)
Comment on attachment 8443523 [details] [diff] [review]
Patch v2 anonymize the path.

Yeah, this seems reasonable, thanks.

a=me for CLOSED TREE as well
Attachment #8443523 - Flags: review?(standard8) → review+
Duplicate of this bug: 1028081
Blocks: 1010064
Keywords: regression
Summary: Update CollectReports() to fix bustage caused by Bug 1010064 → Update CollectReports() to fix c-c bustage caused by Bug 1010064
Bah. I forgot to paste the changeset here:
http://hg.mozilla.org/comm-central/rev/19032f8e6a01
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 33.0
Duplicate of this bug: 1028604
You need to log in before you can comment on or make changes to this bug.