Collection icon rounds all app icons, but should only round E.me icons

VERIFIED FIXED in 2.0 S6 (18july)

Status

VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ranbena, Assigned: amirn)

Tracking

unspecified
2.0 S6 (18july)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

STR:
1. Drop a square shaped app into any Smart Collection.
2. Click on the SC and drag the newly added app to the first (left most) spot.
3. Return to homescreen.
4. Observer the newly added app centered in the SC icon.

Expected: The icon is square shaped
Actual: The icon is rounded.
Created attachment 8444063 [details]
screenshot.png

In the screenshot you can see the "info" app being displayed rounded within The Social SC icon.
Blocks: 989848
Blocks: 1017954
No longer blocks: 989848
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
Whiteboard: [systemsfe]
(Assignee)

Updated

5 years ago
Summary: [Collection app] Generated icon rounds all app icons → Collection icon rounds all app icons, but should only round E.me icons
(Assignee)

Comment 2

5 years ago
Created attachment 8455258 [details] [review]
Pull Request

Considering the alternatives, this patch applies the most simple solution for the bug.
Attachment #8455258 - Flags: review?(kgrandon)
Attachment #8455258 - Flags: review?(crdlc)
(Assignee)

Updated

5 years ago
Assignee: nobody → amirn
Comment on attachment 8455258 [details] [review]
Pull Request

It makes sense and LGTM, r+
Attachment #8455258 - Flags: review?(crdlc) → review+
Comment on attachment 8455258 [details] [review]
Pull Request

I took a look at the patch and it looks fine to me. Also I think Cristians review will suffice here. Thanks!
Attachment #8455258 - Flags: review?(kgrandon)
(Assignee)

Comment 5

5 years ago
landed: https://github.com/mozilla-b2g/gaia/commit/7eb98b5

https://tbpl.mozilla.org/?rev=2af842a3d63513fad8e2a18ee93289e8527eaaa9&tree=Gaia-Try
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Blocks: 989848
No longer blocks: 1017954
(Assignee)

Updated

5 years ago
Blocks: 1048005
(Assignee)

Comment 6

5 years ago
Comment on attachment 8455258 [details] [review]
Pull Request

[Approval Request Comment]

This is a dependency required for landing bug 1048005.

[Bug caused by] (feature/regressing bug #): regression
[User impact] if declined: Collection icons will display rounded app icons for all apps
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: only round icons for E.me web results
Attachment #8455258 - Flags: approval-gaia-v2.0?
Comment on attachment 8455258 [details] [review]
Pull Request

BLocking on this given this dependency is required for landing bug 1048005 and clearing the approval here.
Attachment #8455258 - Flags: approval-gaia-v2.0?
blocking-b2g: --- → 2.0+
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S6 (18july)

Comment 9

4 years ago
Created attachment 8531423 [details]
VIDEO0101.mp4

This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.