Closed Bug 1028681 Opened 5 years ago Closed 5 years ago

[Collection app] Contacts and Phone apps cannot be added to Smart Collections

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: ranbena, Assigned: kgrandon)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

STR:
1. Drag "Gallery", "Phone" and "Contacts" apps onto a Smart Collection.
2. Open that SC.
3. Observe that only "Gallery" is displayed.

Probably has to do with the fact that these apps are endpoints inside the Communications app.
Blocks: 1015336
No longer blocks: vertical-homescreen
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Whiteboard: [systemsfe]
Instead of the applicationId, we should be sending an identifier:

https://github.com/mozilla-b2g/gaia/blob/master/shared/elements/gaia_grid/js/grid_dragdrop.js#L132
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.0 S5 (4july)
Attached file Github pull request
Working on a test.
Comment on attachment 8444247 [details] [review]
Github pull request

Hey Ran - could you give this one a review? The bulk of it adding a test to make sure we don't break this feature again :)

Thanks!
Attachment #8444247 - Flags: review?(ran)
Kevin, I put a few questions up on Github.

Btw, can't test the l10n cause for some reason it stays in English on homescreen even though changed to French. Don't know if this indicated another bug.
Thanks! Updated the PR. Should not be necessary to test for L10n here, but if there is a problem let's handle it in another bug.
Attachment #8444247 - Flags: review?(ran) → review+
Landed: https://github.com/mozilla-b2g/gaia/commit/7f28d5341ac20963cfd7df0deea42baa8eb6b93d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1028971
This should block 2.0 as it impacts apps and bookmarks.
blocking-b2g: 2.0? → 2.0+
Attached video VIDEO0103_Compress.MP4
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
You need to log in before you can comment on or make changes to this bug.