Closed Bug 1028692 Opened 6 years ago Closed 6 years ago

[Collection app] Deleted Smart Collections reappear after restart

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: ranbena, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

STR:
1. Install a new Smart Collection.
2. Remove it from homescreen.
3. Restart device.

Expected: The deleted SC doesn't appear.
Actual: It's back baby.
Blocks: 1015336
No longer blocks: vertical-homescreen
blocking-b2g: --- → 2.0?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+]
Whiteboard: [systemsfe]
Duplicate of this bug: 1028738
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Github pull request
Attachment #8444257 - Flags: review?(kgrandon)
Comment on attachment 8444257 [details]
Github pull request

Looks good, thanks!
Attachment #8444257 - Flags: review?(kgrandon) → review+
Landed: https://github.com/mozilla-b2g/gaia/commit/4452a4553926d2adf41488f1024fe1399e9a5014
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 2.0? → 2.0+
Target Milestone: --- → 2.0 S5 (4july)
Attached video VIDEO0099_Compress.MP4
This issue has been successfully verified on Flame 2.0:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2


This issue has been successfully verified on Flame 2.1:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.