All users were logged out of Bugzilla on October 13th, 2018

Deleted collections re-appear after an OTA update

RESOLVED DUPLICATE of bug 1028692

Status

RESOLVED DUPLICATE of bug 1028692
4 years ago
4 years ago

People

(Reporter: fabrice, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
All this is while running nightly builds.

- Running the build updated Saturday 06/21, I deleted the 4 collections that are by default on the homescreen (Social, Games, Music, Entertainment).
- Sunday, I got an OTA update.

1) The 4 collections are back on my homescreen. The return of the revenge of the deleted collections!

2) I can't remove them anymore... I get the "Delete Collection" dialog but nothing happens, except this very strange error in logcat:
I/GeckoDump(15211): XXX FIXME : Got a mozContentEvent: activity-choice
I/Gecko   (15211): [Parent 15211] WARNING: waitpid failed pid:15563 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 261
I/Gecko   (15211): IPDL protocol error: Handler for AsyncMessage returned error code
I/Gecko   (15211): 
I/Gecko   (15211): ###!!! [Parent][DispatchAsyncMessage] Error: Processing error: message was deserialized, but the handler returned false (indicating failure)
I/Gecko   (15211): 
I/Gecko   (15211): [Parent 15211] WARNING: pipe error (237): Connection reset by peer: file ../../../gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 450
I/Gecko   (15211): [Parent 15211] WARNING: pipe error (234): Connection reset by peer: file ../../../gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 450
I/Gecko   (15709): ###################################### forms.js loaded
I/Gecko   (15709): ############################### browserElementPanning.js loaded
I/Gecko   (15709): ######################## BrowserElementChildPreload.js loaded


And we kill the preallocated process!
We should find out if they are not really deleted from datastore, or we are running our upgrade scripts when we should not be.
Blocks: 1017954
I think this is the same problem as bug 1028692.
No longer blocks: 1017954
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1028692
You need to log in before you can comment on or make changes to this bug.