Note: There are a few cases of duplicates in user autocompletion which are being worked on.

B2G hamachi_eng_nightly failing with "Giving up on gecko git revision for 31de1a84b27f."

RESOLVED FIXED

Status

Release Engineering
Buildduty
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
b2g_mozilla-central_hamachi_eng_nightly on 2014-06-23 08:58:42 PDT for push 31de1a84b27f

slave: bld-linux64-spot-077

{
09:14:07     INFO - Sleeping 30 seconds before retrying
09:14:37  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:14:37     INFO - Sleeping 30 seconds before retrying
09:15:07  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:15:07     INFO - Sleeping 30 seconds before retrying
09:15:38  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:15:38     INFO - Sleeping 30 seconds before retrying
09:16:08  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:16:08     INFO - Sleeping 30 seconds before retrying
09:16:38  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:16:38     INFO - Sleeping 30 seconds before retrying
09:17:09  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:17:09     INFO - Sleeping 30 seconds before retrying
09:17:39  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:17:39     INFO - Sleeping 30 seconds before retrying
09:18:09  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:18:09     INFO - Sleeping 30 seconds before retrying
09:18:40  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:18:40     INFO - Sleeping 30 seconds before retrying
09:19:10  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:19:10     INFO - Sleeping 30 seconds before retrying
09:19:41  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:19:41     INFO - Sleeping 30 seconds before retrying
09:20:11  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:20:11     INFO - Sleeping 30 seconds before retrying
09:20:41  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:20:41     INFO - Sleeping 30 seconds before retrying
09:21:12  WARNING - Error: Mapper returned a revision of None; maybe it needs more time.
09:21:12    FATAL - Giving up on gecko git revision for 31de1a84b27f.
09:21:12    FATAL - Running post_fatal callback...
09:21:12    FATAL - Exiting -1
program finished with exit code 255
elapsedTime=1343.681275
========= Finished 'scripts/scripts/b2g_build.py --target ...' failed (results: 2, elapsed: 22 mins, 28 secs) (at 2014-06-23 09:21:16.582408) =========
}
(Reporter)

Comment 1

3 years ago
17:57 <RyanVM> edmorley|sheriffduty: I wonder if the mapper is dying on those m-c b2g nightlies because it's the long hg rev instead of the short form
17:59 <RyanVM> edmorley|sheriffduty: I just triggered new ones with the short-form rev
17:59 <RyanVM> we'll see what happens
17:59 <edmorley|sheriffduty> RyanVM: oh they were the manually triggered ones?
17:59 <RyanVM> edmorley|sheriffduty: yes
18:00 <RyanVM> edmorley|sheriffduty: so I wonder if there's a mapper bug if the long-form rev is used
(Reporter)

Comment 2

3 years ago
<aki> Callek|Buildduty: edmorley|sheriffduty http://cruncher/mapper/gecko/git/31de1a84b27f works now, so a retrigger should work

Retriggered on:
https://tbpl.mozilla.org/?rev=31de1a84b27f&jobname=_eng

Updated

3 years ago
Duplicate of this bug: 1028991
per https://tbpl.mozilla.org/?rev=31de1a84b27f&jobname=_eng looks fixed

Of course there appears to be 2 that were triggered in short succession of each other, just as an FYI
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.