[UX] Define experience for tracking-blocking

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: madhava, Assigned: phlsa)

Tracking

unspecified
x86
All
Points:
13
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ux])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
The proposed experience encompasses

1. The ability to turn on a more active variant of Do Not Track that actually blocks tracking (through a pref)
2. Some indicator in the browser (analogous to our mixed content indication) that DNT is being enforced for the current site/page
3. The ability to turn tracking-blocking off for a site while on it if the blocking is causing a user to have difficulties with the site (should be unusual).
Summary: [UX] Define experience for third-party cookies → [UX] Define experience for tracking-blocking

Updated

4 years ago
QA Whiteboard: [qa-]
Whiteboard: [ux]
Assignee: nobody → philipp
Added to Iteration 33.2
Status: NEW → ASSIGNED
Iteration: --- → 33.2
Points: --- → 13
I'll have to deal with a different fire drill next week, so I'm unassigning myself again for now.
Assignee: philipp → nobody
Status: ASSIGNED → NEW
OS: Mac OS X → All

Updated

4 years ago
Iteration: 33.2 → ---

Updated

4 years ago
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Iteration: --- → 33.3
Duplicate of this bug: 1033880
Philipp, I'm so glad you're working on this. I didn't know about this bug until now and did some work in https://bugzilla.mozilla.org/show_bug.cgi?id=1033880 to try to write down what we are thinking about. Can we meet sometime this week to talk about the flow requirements?

Thanks,
Monica

Updated

4 years ago
Flags: firefox-backlog+
Created attachment 8459849 [details]
UI Mockup

This shows the preferences UI, the notification UI and the control UI for tracking blocking.
It is, in large parts, merged with the UI for mixed content. Further description is in the mockup.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 6

4 years ago
(In reply to Philipp Sackl [:phlsa] from comment #5)
> Created attachment 8459849 [details]
> UI Mockup
> 
> This shows the preferences UI, the notification UI and the control UI for
> tracking blocking.
> It is, in large parts, merged with the UI for mixed content. Further
> description is in the mockup.

Really like this mockup, Philipp!

One thing to think about is the ctrl-I functionality and Larry. How does the tracking protection shield interact with instances where we pop up Larry on a site?
(In reply to Alex Fowler from comment #6)
> Really like this mockup, Philipp!
Thanks!

> One thing to think about is the ctrl-I functionality and Larry. How does the
> tracking protection shield interact with instances where we pop up Larry on
> a site?
It shouldn't interact with Larry at all. Larry extends from the site identity icon and not from the shield, so they can happily coexist :)
I'm not sure what you mean by ctrl-I functionality. That opens page info which is entirely separate.
Is there a separate bug for tracking what sites break tracking protection? Or a bug to put a "report why you unblocked this site?" thing back in so that we can easily report sites that break it?
You need to log in before you can comment on or make changes to this bug.