Closed Bug 1041748 Opened 5 years ago Closed 5 years ago

Breakdown: Implement UI for tracking protection

Categories

(Firefox :: General, defect)

33 Branch
x86
All
defect
Not set
Points:
5

Tracking

()

RESOLVED FIXED
Iteration:
34.1

People

(Reporter: phlsa, Assigned: Unfocused)

References

Details

Attachments

(1 file)

Break down the engineering work for implementing the UI for tracking protection as specified in bug 1029193.
Flags: firefox-backlog+
Added to Iteration 34.1
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Iteration: --- → 34.1
Points: --- → 5
Duplicate of this bug: 1030979
Depends on: 1043779
Depends on: 1043780
Depends on: 1043797
Depends on: 1043801
Depends on: 1043803
Depends on: 1043805
Breakdown complete.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Hi Philipp,

Thanks for working on the UI for this!  I'd like to propose a few slight changes to the mockup.

1) Can we add back the "Keep Blocking" option for Mixed Content Blocker (and also have one for Tracking Protection).  This way, a user we who see's the Options button and wants to take an action has an option besides disabling protection.

2) For Mixed Content Blocker, the disable protection button said "Disable Protection for This Page", because the decision doesn't persist.  Can we keep that same text instead of "Disable Protection for now".  The protection is disabled while the user is navigating that website, and as soon as they leave that website and/or switch tabs, the protection is back on.

3) This text isn't quite right:
Parts of this web page have been transmitted over an unencrypted connection and have been blocked

The mixed content hasn't been transmitted yet.  Also, in other mixed content strings, we use website (http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/browser.properties#299).  To be consistent with those other messages, I propose:

"Unencrypted elements on this website have been blocked for your protection."

If the "for your protection" part is too strong, we could leave that out.
As discussed in IRC:

1) We'll add an x as a close button instead to be consistent with other permissions doorhanger UI.

2) Let's keep using »for now« since it is the most accurate way to briefly describe the (slightly counterintuitive) behavior.

3) Let's use »Some unencrypted elements on this website have been blocked for your protection.«
(In reply to Philipp Sackl [:phlsa] from comment #6)
> 3) Let's use »Some unencrypted elements on this website have been blocked
> for your protection.«

Slight correction. It should be:
»Some unencrypted elements on this website have been blocked.«
You need to log in before you can comment on or make changes to this bug.