[B2G][Browser]Typing in a web address opens a blank white page

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Browser
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: astole, Assigned: lightsofapollo)

Tracking

({regression, smoketest})

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed, b2g-v2.1 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8445230 [details]
logcat

When loading a web address, a blank white page loads and the address bar disappears. The webpage can be added to the homescreen and when opened from the homescreen, it loads correctly.

Repro Steps:
1) Update a Flame to BuildID: 20140624040203
2) Open Browser
3) Load a website

Actual:
Browser loads a blank white screen

Expected:
Browser loads the correct web address

2.1 Environmental Variables:
Device: Flame 2.1
BuildID: 20140624040203
Gaia: 45479c07cb6ba8c733093d6ee32c767c090c9a28
Gecko: e86b84998b18
Version: 33.0a1
Firmware Version: v122

Repro frequency: 2/2, 100%
See attached: logcat, Screenshot
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
Keywords: qaurgent
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
blocking-b2g: 2.0? → 2.1?
(Reporter)

Comment 1

4 years ago
Created attachment 8445234 [details]
Screenshot

This issue does not occur on the latest 2.0. Websites load correctly in the browser.

v2.0 Environmental Variables:
Device: Flame v2.0 MOZ
BuildID: 20140624000201
Gaia: 9d2f7bd16a8dc0c74c97c5a40d2f0731f3dfff4b
Gecko: f118b45daada
Version: 32.0a2
Firmware Version: v122

Updated

4 years ago
QA Contact: ddixon
(Assignee)

Updated

4 years ago
Assignee: nobody → jlal
(Assignee)

Comment 2

4 years ago
The problem in the #toolbar-end element which is hiding the entire browser iframe which is loading just fine so this is a pure display error.
(Assignee)

Comment 3

4 years ago
Unlikely a gecko bug this works just fine on 1.4 on mozilla-central
(Assignee)

Comment 4

4 years ago
By bisecting this is the cause 4fd21dac243e496c2a027cda5a1b9d1e97f41b22 will revert / test after lunch

Updated

4 years ago
Blocks: 1026387
Keywords: qaurgent, regressionwindow-wanted
Regressing patch also landed on 2.0 at 8:23am this morning, so we need this backed out on 2.0 & 2.1.
blocking-b2g: 2.1? → 2.0?
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: unaffected → affected
I am also observing this issue in the Email inbox
Created attachment 8445367 [details]
InboxIsBlank.txt
Fixed by backing out bug 1026387.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
status-b2g-v2.0: affected → fixed
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.0 S5 (4july)

Updated

4 years ago
Duplicate of this bug: 1030008

Comment 10

4 years ago
The issue still reproduces in today's master build

Flame 2.1
BuildID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1
(In reply to Natalya Kot [:nkot] from comment #10)
> The issue still reproduces in today's master build
> 
> Flame 2.1
> BuildID: 20140625040202
> Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
> Gecko: a19e0434ea52
> Version: 33.0a1

The build you have does not contain the backout of the patch here.

Comment 12

4 years ago
Okay, we've built the new build by pulling the latest Gaia and the issue no longer occurs - Browser opens up and loads pages and Email inbox displays content properly.

Verified Fixed.

BuildID: 20140625040202
Gaia: 3ba8af193415e274726255ebb286057bd04dd893
Gecko: a19e0434ea52
Version: 33.0a1
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.