Closed Bug 1029635 Opened 6 years ago Closed 6 years ago

[search] Marketplace search should return icons of varying sizes (depending on our screen size)

Categories

(Marketplace Graveyard :: API, defect)

Avenir
x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
2014-07-01

People

(Reporter: jlal, Assigned: cvan)

References

Details

Right now we hit the following endpoint: https://marketplace.firefox.com/api/v1/apps/search/rocketbar this returns the 64x64 icons we ideally can specify which size we want something like: https://marketplace.firefox.com/api/v1/apps/search/rocketbar/?q=game&iconSize=128 or return icons like this:

icons: {
  "128": "...",
  "64": "..."
}

Either would let us pick the size we need depending on the app and screen size.
@cvan can you help us update this endpoint?
Flags: needinfo?(cvan)
(In reply to James Lal [:lightsofapollo] from comment #1)
> @cvan can you help us update this endpoint?

Sure. Is it okay to deprecate the `icon` field then? Also, could you please file a bug in the Marketplace product? https://bugzilla.mozilla.org/enter_bug.cgi?product=Marketplace&component=API Thanks!
Flags: needinfo?(cvan)
What's the user impact of this bug? Can this cause pixelated icons on rocketbar search results?
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Flags: needinfo?(jlal)
(In reply to Christopher Van Wiemeersch [:cvan] from comment #2)
> Sure. Is it okay to deprecate the `icon` field then? Also, could you please
> file a bug in the Marketplace product?
> https://bugzilla.mozilla.org/enter_bug.cgi?product=Marketplace&component=API
> Thanks!

We can deprecate the icon field in 2.0, as long as we get the relevant gaia fix in as well. My preference would be to actually leave the icon field as-is, but potentially dynamic in nature if we change a query parameter for the icon size. I would assume that this would be best for performance on these mobile devices.
(In reply to Christopher Van Wiemeersch [:cvan] from comment #5)
> Can we have https://marketplace.firefox.com/api/v1/apps/search/rocketbar
> return `icon` and
> https://marketplace.firefox.com/api/v2/apps/search/rocketbar return `icons`
> (notice the `/v2/` in the URL)?

That would be easy for us to implement in gaia, so sounds good to me.
Whiteboard: [systemsfe]
Note that we're going to be recommending that third party developers use larger icon sizes (512x512px) to accomodate higher resolution devices, so getting the appropriate sizes is going to be even more important in the future.
Assignee: nobody → cvan
User impact is fuzzy/poor looking icons on larger devices. This is essentially the same issue that we had in the past with the e.me icons ( I found this while looking at the other issue )
Flags: needinfo?(jlal)
Given that the issue is server-side, I won't block on this, but we can definitely can look into getting a fix here.
No longer blocks: vertical-homescreen
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking?]
Whiteboard: [systemsfe]
Component: Gaia::Homescreen → API
Product: Firefox OS → Marketplace
Version: unspecified → Avenir
Jason just to clarify while the majority (but I suspect it is trivial too) is server side we also need to land some changes in gaia to take advantage of this (particularly if we choose different icons based on screen size).
(In reply to James Lal [:lightsofapollo] Unvailable until 6/30 from comment #10)
> Jason just to clarify while the majority (but I suspect it is trivial too)
> is server side we also need to land some changes in gaia to take advantage
> of this (particularly if we choose different icons based on screen size).

We probably have another bug on file for the gaia change to follow from this then.
https://github.com/mozilla/zamboni/commit/9572b37

V1 has only `icon`:
https://marketplace-dev.allizom.org/api/v1/apps/search/rocketbar/?q=penguin

V2 has `icons` instead of `icon`:
https://marketplace-dev.allizom.org/api/v2/apps/search/rocketbar/?q=penguin

Let me know if this format works well for y'all.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-07-01
Depends on: 1032933
Christopher - thanks for the quick response on this. Any idea when this will hit production? When I hit the following URL I still see the old structure. https://marketplace.firefox.com/api/v2/apps/search/rocketbar/?q=penguin

FYI - we have bug 1032933 ready to go, but I just wanted to do some testing against production before landing. Thanks!
Flags: needinfo?(cvan)
In roughly 30 min. We do weekly pushes on Tuesdays.
Flags: needinfo?(cvan)
Awesome, thanks for the quick response on this guys. We will get the gaia part of this in soon.
You need to log in before you can comment on or make changes to this bug.