Views: Switching between Threads w/Unread and Unread causes display oddities

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

17 years ago
Seen with 0.9.4 branch on All platforms, both Modern and Classic themes

When switching between message views Threads with Unread and Unread,
particularly when there are long nested threads expanded, I see threading
display line/twistie oddities.  This happens particularly to threads having only
one message (no replies) which appear underneath a multi-level nested thread.

Scenario:
1.  Open a newsgroup such as n.p.m.mail-news having many nested threads. Open in
View All messages, threaded mode.
2.  Make sure there are unread messages in various threads, and at different
nesting levels in the threads.  Doesn't matter at this point whether threads
having unread messages are in expanded or collapsed state or mix of both.
3.  Switch to View Threads with Unread.  The view opens with threads in
collapsed state.
4.  While in View Threads with Unread, expand some of the threads. If not
already this way, mark a few top level messages as read and some deeply nested
level messages unread.  Particularly try to have unread messages nested deeply
where the thread below only has one/topic message (no replies).
5.  Switch the view to View Unread.

Result:  Particularly on single message threads, there will be phantom threading
lines or twisties where there shouldn't be.

Will attach at least one screenshot where this is shown.
(Reporter)

Comment 1

17 years ago
I looked for bugs on this, but didn't spot any obvious ones. Sorry if duplicated.
QA Contact: esther → laurel
(Reporter)

Comment 2

17 years ago
Created attachment 51950 [details]
screenshot in Unread view
(Reporter)

Comment 3

17 years ago
To clarify a bit:  This phantom threading display effect can happen in View
Unread on either an unread thread having no other message members in any view (a
message which has no replies even in View All, the thread has only one total
message and it is unread) or a thread comprised of multiple messages where there
is only one unread reply.
(Reporter)

Comment 4

17 years ago
still exists dec14 commercial trunk

Updated

16 years ago
Blocks: 157217

Comment 5

15 years ago
Created attachment 124586 [details]
mbox folder for reproducing the problem

This mbox allows to reproduce the problem. Simply extract the zip, and copy the
resulting file into e.g. the folder where your "Local Folders" acoount resides.

(the mbox contains messages from a public mailing list at openoffice.org)

Then
- start Mozilla MailNews
- open your "Local Folders" account
- enter the folder "broken_thread_display"
- chose View|Threads|Unread
- ensure that the view is "threaded" (by clicking on the "Thread" Header, if
necessary)

actual result:
The unread messages are shown, but the lines connecting the messages are
totally garbled.

expected result:
well, the connector lines should not be garbled ...

Comment 6

15 years ago
This bug is in Mozilla MailNews since at least 0.9.4. It makes the "Threads
Unread" view mode somewhat useless, as advancing top-to-bottom in such a broken
view destroys the coherence in the thread (by jumping forth and back between
different sub threads), it would be good to fix this in 1.4.

The more as it seems that 1.4 is to be the main successor for 1.0.x, and 1.5
will take a while to appear, such bugs should be fixed before the release.
Flags: blocking1.4?

Comment 7

15 years ago
Created attachment 124844 [details]
screenshot showing the  result of the mbox file

This screenshot shows the result when displaying the attached mbox file in
"views|threads|unread" + threaded mode. IMO, it better shows the severity of
this bug than attachment 51950 [details].

Comment 8

15 years ago
Looking at the original screen shot (attachment 51950 [details]), I am not completely sure
if the bug reported here is exactly the same as the one I tried to report. Hmm.
I submitted an extra bug for this (bug 208324), and remove my "blocking
1.4"-request from this one here.
Sorry for any spam I caused with temporarily awakening this dead corpse :)
Flags: blocking1.4?

Comment 9

15 years ago
Comment on attachment 124586 [details]
mbox folder for reproducing the problem

obsoleting this attachment - moved to bug 208324
Attachment #124586 - Attachment is obsolete: true

Comment 10

15 years ago
Comment on attachment 124844 [details]
screenshot showing the  result of the mbox file

obsoleting this attachment - moved to bug 208324
Attachment #124844 - Attachment is obsolete: true

Updated

14 years ago
Blocks: 236849

Comment 11

14 years ago
The "phantom threading line" described in the original report and seen in the 
screenshot may be bug 93426.

I don't believe Laurel is reading these bugs anymore; I've never seen this 
symptom, and Frank's symptom was rediverted elsewhere.  =>WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.