Intermittent issues loading try pushlog and json-pushes

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/701] )

(Reporter)

Description

4 years ago
TBPL is timing out (timeout is 20s) frequently when loading single push try pages, eg:
https://tbpl.mozilla.org/?tree=Try&rev=41a09a4fa30a

...when it tries to load json-pushes, eg:
https://hg.mozilla.org/try/json-pushes?full=1&changeset=41a09a4fa30a

See bug 959769 for prior instances of this. It would be good if we could see if there is something other than a try repo reset that could fix this longer term :-)
At first pass, this is related to cache invalidation when pushes to try are aborted (network drop or ^C).

If that is the case, then we'd expect the following to be true:
 - a retry in about 5 minutes succeeds
 - you'd see similar behavior on treeherder at the same time

If you can confirm those the next times this happens, we can move this to blocking the cache invalidation fix.
Flags: needinfo?(emorley)
(Reporter)

Comment 2

4 years ago
I'll try to keep an eye out for when I see this consistently again - the last time pages seemed to eventually load quicker than 5 mins, but I could be mis-rememebering... hmm
Flags: needinfo?(emorley)
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1042233

Updated

4 years ago
Component: Server Operations: Developer Services → Mercurial: hg.mozilla.org
Product: mozilla.org → Developer Services

Updated

4 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/56]

Updated

4 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/56] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/701] [kanban:engops:https://kanbanize.com/ctrl_board/6/56]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/701] [kanban:engops:https://kanbanize.com/ctrl_board/6/56] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/701]

Comment 4

4 years ago
I'm going to say this is related to typical Try scaling issues. I see little value in keeping this bug open.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.