Add Google logo to search plugin so about:newtab can use it

VERIFIED FIXED in Firefox 31

Status

()

Firefox
Search
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: adw, Assigned: adw)

Tracking

Trunk
Firefox 33
Points:
1
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox30 unaffected, firefox31+ verified, firefox32+ verified, firefox33 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Created attachment 8446013 [details] [diff] [review]
patch

Boriss posted these images in bug 1006203 comment 24 and 25.
Attachment #8446013 - Flags: review?(MattN+bmo)
(Assignee)

Comment 1

4 years ago
Marco, could we add this to the current iteration, please?
QA Whiteboard: [qa+]
status-firefox30: --- → unaffected
status-firefox31: --- → affected
status-firefox32: --- → affected
tracking-firefox31: --- → ?
tracking-firefox32: --- → ?
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
Comment on attachment 8446013 [details] [diff] [review]
patch

Review of attachment 8446013 [details] [diff] [review]:
-----------------------------------------------------------------

The 65x26 image is actually 65x25.
Attachment #8446013 - Flags: review?(MattN+bmo) → review-
(Assignee)

Comment 3

4 years ago
Created attachment 8446053 [details] [diff] [review]
patch 2
Attachment #8446013 - Attachment is obsolete: true
Attachment #8446053 - Flags: review?(MattN+bmo)
Comment on attachment 8446053 [details] [diff] [review]
patch 2

That's better. Thanks.
Attachment #8446053 - Flags: review?(MattN+bmo) → review+
Added to Iteration 33.2
Flags: needinfo?(mmucci)
QA Contact: petruta.rasa
https://hg.mozilla.org/mozilla-central/rev/5563efd9704c
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
(Assignee)

Comment 8

4 years ago
Comment on attachment 8446053 [details] [diff] [review]
patch 2

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Bug 962490 added a search field to about:newtab and landed on 31.  The logo of the currently selected search engine, if available, appears to the left of the search field.

User impact if declined:
When Google is the currently selected engine, its logo will not appear.  about:newtab gracefully handles missing logos, though.

Testing completed (on m-c, etc.):
manual testing, automated testing on m-c

Risk to taking this patch (and alternatives if risky):
very low

String or IDL/UUID changes made by this patch:
none
Attachment #8446053 - Flags: approval-mozilla-beta?
Attachment #8446053 - Flags: approval-mozilla-aurora?
status-firefox33: --- → fixed
tracking-firefox31: ? → +
tracking-firefox32: ? → +
Attachment #8446053 - Flags: approval-mozilla-beta?
Attachment #8446053 - Flags: approval-mozilla-beta+
Attachment #8446053 - Flags: approval-mozilla-aurora?
Attachment #8446053 - Flags: approval-mozilla-aurora+
Verified that the Google logo is correctly displayed on Firefox 31 beta 6, Aurora 32.0a2 and Nightly 33.0a1 2014-06-29 on about:newtab page under Win 7 64-bit, Ubutnu 12.10 32-bit and Mac OSX 10.9.3.
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
status-firefox31: fixed → verified
status-firefox32: fixed → verified
status-firefox33: fixed → verified
You need to log in before you can comment on or make changes to this bug.