[B2G][Contacts]Incorrect message displays when importing contacts from Gmail's My Contacts folder equals zero

RESOLVED DUPLICATE of bug 875159

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 875159
4 years ago
4 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 unaffected)

Details

(Whiteboard: [2.0-flame-test-run-2], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8446076 [details]
Logcat Import Gmail Contacts Issue

User selects Contacts and goes to Settings to import contacts from Gmail with an active internet connection from an account with no contacts in the My Contacts folder of Gmail. When user selects the Gmail button and accepts on the Request for Permission page, the Contacts page reads all your friends are imported even though there is nothing visible.

Pre-requisites:
1. Have an active internet Connection
2. Have a Gmail account that has no contacts within the My Contacts folder

Repro Steps:
1) Update a Flame to 20140625000201
2) Tap Contacts App and select gear icon to access Settings
3) Tap Gmail and accept on the Request for Permission page
4) Observe device behavior

Actual:
Message displays “All your friends are imported”

Expected:
Message displays “No contacts available to import”

Notes:
Repro frequency: (10/10, 100%)
Link to failed test case: https://moztrap.mozilla.org/manage/case/7073/
See attached: 
a) video clip = https://www.youtube.com/watch?v=h8cgI89voXk
b) Flame logcat not provided due to issue with https://bugzilla.mozilla.org/show_bug.cgi?id=1010993
c) Open C logcat provided on account of issue in b) above

Environmental Variables:
Device: Flame 2.0
Build ID: 20140625000201
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Gecko: 79712bd7b60d
Version: 32.0a2 (2.0)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
(Reporter)

Comment 1

4 years ago
This issue reproduces on Flame 1.4, Buri 1.4, Open C 1.4, Buri 1.3, and Open C 1.3 following the STR from Comment 0. The on device screen message reads All your friends are imported even though no contacts appear. 

Environmental Variables:
Device: Flame 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Buri 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Open_C 1.4
Build ID: 20140625000201
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Gecko: cddf88f78632
Version: 30.0 (1.4)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Buri 1.3
Build ID: 20140625024001
Gaia: 7a25ded52cf1164196098545be4fa7d5111fd526
Gecko: 8ef1dadd6278
Version: 28.0 (1.3)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

1.3 Environmental Variables:
Device: Open_C 1.3
BuildID: 20140505052400
Gaia: Unknown Git commit; build date shown here.
Gecko:
Version: 28.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

____________________________________________________________________________________________________
This issue does not reproduce on Flame 2.1 following the STR from Comment 0. The on device screen message appears as expected No contacts available to import. 

2.1 Environmental Variables:
Device: Flame Master
Build ID: 20140625040202
Gaia: 57da30f405ba37a5d4844f32bb292271b81faee2
Gecko: a19e0434ea52
Version: 33.0a1 (Master)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ktucker)
Resolution: --- → DUPLICATE
Duplicate of bug: 875159
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
You need to log in before you can comment on or make changes to this bug.