bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Regression with drawing images at the top level

REOPENED
Unassigned
(NeedInfo from)

Status

()

Core
Layout: Images
REOPENED
4 years ago
4 years ago

People

(Reporter: milan, Unassigned, NeedInfo)

Tracking

({regression})

32 Branch
x86
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Created attachment 8446077 [details]
Screengrab of what the image looks like half way through

Go to bug 1029954 and click on the second on third attachment (direct link https://bugzilla.mozilla.org/attachment.cgi?id=8445646 and https://bugzilla.mozilla.org/attachment.cgi?id=8445647) and observe what the resulting drawing looks like.  The image is skewed until drawn fully, but once fully drawn settles into a correct result.
I'm not sure this is a layout bug, but it is a regression from bug 298619 where we started paying attention to the css image-orientation value, and these images do have EXIF data.  Backing out bug 289619 does fix this problem.
Blocks: 298619
Component: Graphics → Layout: Images
(In reply to Milan Sreckovic [:milan] from comment #1)
>...
> these images do have EXIF data.  Backing out bug 289619 does fix this

That would be bug 298619 instead.
Looks like a dup of bug 997604 ?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997604
While the fix to bug 997604 improved the behavior here a great deal, it didn't completely fix everything - so either this is not a (complete) dupe of bug 997604 or we need a more complete fix to bug 997604. I'll attach the movies of before and after.
Status: RESOLVED → REOPENED
Flags: needinfo?(seth)
Resolution: DUPLICATE → ---
Created attachment 8448181 [details]
Before the fix to bug 997604 applied
Created attachment 8448182 [details]
With the patch from bug 997604 applied

Got a lot better with the patch from bug 997604, but we still display it the wrong aspect ratio until fully decoded and then we snap to normal.
You need to log in before you can comment on or make changes to this bug.