Closed Bug 1030734 Opened 6 years ago Closed 6 years ago

crash in android.content.ActivityNotFoundException: at android.app.Instrumentation.checkStartActivityResult(Instrumentation.java)

Categories

(Android Background Services Graveyard :: Core, defect, critical)

Firefox 33
All
Android
defect
Not set
critical

Tracking

(firefox32 unaffected, firefox33 fixed, fennec33+)

RESOLVED FIXED
Firefox 33
Tracking Status
firefox32 --- unaffected
firefox33 --- fixed
fennec 33+ ---

People

(Reporter: cos_flaviu, Assigned: nalexander)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-59b526a2-813c-40b4-9c84-475ac2140626.
=============================================================
Environment: 
Device: Google Nexus 10 (Android 4.4.2);
Build: Nightly 33.0a1 (2014-06-26);

Steps to reproduce:
1. Launch fennec with a clean profile;
2. Go to Settings -> Sync and login with valid credentials;
3. Tap on the 'Back to browsing' button.

Expected result:
The user is successfully logged in.

Actual result:
Fennec crashes.

Stacktrace:
android.content.ActivityNotFoundException: Unable to find explicit activity class {org.mozilla.gecko/org.mozilla.gecko.BrowserApp}; have you declared this activity in your AndroidManifest.xml?
	at android.app.Instrumentation.checkStartActivityResult(Instrumentation.java:1628)
	at android.app.Instrumentation.execStartActivity(Instrumentation.java:1424)
	at android.app.Activity.startActivityForResult(Activity.java:3424)
	at android.app.Activity.startActivityForResult(Activity.java:3385)
	at android.app.Activity.startActivity(Activity.java:3627)
	at android.app.Activity.startActivity(Activity.java:3595)
	at org.mozilla.gecko.sync.setup.activities.ActivityUtils.openURLInFennec(ActivityUtils.java:67)
	at org.mozilla.gecko.fxa.activities.FxAccountVerifiedAccountActivity$1.onClick(FxAccountVerifiedAccountActivity.java:62)
	at android.view.View.performClick(View.java:4438)
	at android.view.View$PerformClick.run(View.java:18422)
	at android.os.Handler.handleCallback(Handler.java:733)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:136)
	at android.app.ActivityThread.main(ActivityThread.java:5017)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:779)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:595)
	at dalvik.system.NativeStart.main(Native Method)
Good: Firefox 33.0a1 (2014-06-25)
Bad: Firefox 33.0a1 (2014-06-26)

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a19e0434ea52&tochange=464bca437658

I think that Bug 929865 is the cause of this regression.
tracking-fennec: --- → ?
Keywords: regression
Assignee: nobody → nalexander
tracking-fennec: ? → 33+
Yeah, this is on me.  Looks like I got the package name wrong at least once:

org.mozilla.gecko/org.mozilla.gecko.BrowserApp

That should be

org.mozilla.fennec/org.mozilla.gecko.BrowserApp
Status: NEW → ASSIGNED
Oops.
Component: General → Core
Product: Firefox for Android → Android Background Services
Version: Trunk → Firefox 33
Blocks: 929865
Attachment #8446882 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/mozilla-central/rev/2c5284563bad
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
(In reply to Richard Newman [:rnewman] from comment #7)
> https://hg.mozilla.org/integration/fx-team/rev/2c5284563bad

Awesome!  Thanks so much for landing this.  Catriona's going away (from work) party was last night.
Blocks: 1032483
You need to log in before you can comment on or make changes to this bug.