Closed Bug 1030740 Opened 5 years ago Closed 5 years ago

NPE in HealthReportBroadcastService.onHandleIntent

Categories

(Android Background Services Graveyard :: Core, defect)

All
Android
defect
Not set

Tracking

(firefox30 wontfix, firefox31 fixed, firefox32 fixed, firefox33 fixed, fennec31+)

RESOLVED FIXED
Firefox 33
Tracking Status
firefox30 --- wontfix
firefox31 --- fixed
firefox32 --- fixed
firefox33 --- fixed
fennec 31+ ---

People

(Reporter: blassey, Assigned: rnewman)

References

Details

Attachments

(1 file, 2 obsolete files)

54 reports on beta

java.lang.NullPointerException
at org.mozilla.gecko.background.healthreport.HealthReportBroadcastService.onHandleIntent(HealthReportBroadcastService.java:104)
at android.app.IntentService$ServiceHandler.handleMessage(IntentService.java:65)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:137)
at android.os.HandlerThread.run(HandlerThread.java:60)

The code logs "Short-circuiting on null intent." after checking for a null intent, but then continues on using the intent.

https://mxr.mozilla.org/mozilla-beta/source/mobile/android/base/background/healthreport/HealthReportBroadcastService.java#104
Attached patch null_intent_FHR.patch (obsolete) — Splinter Review
Assignee: nobody → blassey.bugs
Attachment #8446540 - Flags: review?(rnewman)
Attached patch null_intent_FHR_beta.patch (obsolete) — Splinter Review
Attachment #8446541 - Flags: review?(rnewman)
Dupe of bug 1025937 which already has fixes.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1025937
Not a dupe. Bug 1025937 only logs that the intent is null. I don't see how it avoids the null intent.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Showing the magical powers of code review -- all of those log statements in Bug 1025937 should have returns, too.

This needs upstreaming, and should be uplifted to follow those incomplete patches. I'm going to steal this so Brad doesn't have to fiddle with pull requests.
Assignee: blassey.bugs → rnewman
Blocks: 1025937
Status: REOPENED → ASSIGNED
Component: General → Core
OS: Mac OS X → Android
Product: Firefox for Android → Android Background Services
Hardware: x86 → All
Version: Trunk → unspecified
Attachment #8446540 - Attachment is obsolete: true
Attachment #8446540 - Flags: review?(rnewman)
Attachment #8446541 - Attachment is obsolete: true
Attachment #8446541 - Flags: review?(rnewman)
Comment on attachment 8446622 [details] [diff] [review]
Patch for uplift.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Giant fail in Bug 1025937: only added logging statements, so didn't fix the bug. This is what we *meant* to land and uplift in that bug.

User impact if declined: 
  Crashes.

Testing completed (on m-c, etc.): 
  Just landed, but this is an obviously safe change.

Risk to taking this patch (and alternatives if risky): 
  None.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8446622 - Flags: approval-mozilla-beta?
Attachment #8446622 - Flags: approval-mozilla-aurora?
tracking-fennec: ? → 31+
https://hg.mozilla.org/mozilla-central/rev/9ef5a684289f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Attachment #8446622 - Flags: approval-mozilla-beta?
Attachment #8446622 - Flags: approval-mozilla-beta+
Attachment #8446622 - Flags: approval-mozilla-aurora?
Attachment #8446622 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.