Closed Bug 1031559 Opened 10 years ago Closed 10 years ago

Expose "Reader mode" option earlier

Categories

(Firefox for Android Graveyard :: Reader View, defect)

x86
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1044947

People

(Reporter: antlam, Unassigned)

Details

Attachments

(1 file)

Attached image prev_rmode_menu1.png
Use case:

I'm reading some stuff on my Android phone and I come across a link to an article. "This seems interesting" I think to myself. So, I tap this link and am presented with the following options in the list:

- Firefox
- Some browser
- Some other browser
- Yet another app

I wonder if we provide a better user experience here and offer up the "Reader mode" as an option earlier on so the user will both know it exists, and can quickly get to the article via Reader mode instead of putting it one step further away.

We might even go as far as saying our Reader mode is awesomest and even just launch the article/link in Reader mode every time.

Thoughts?
This might also be seen as an additional way to help us on bug 1011712
(In reply to Anthony Lam (:antlam) from comment #0)
> Created attachment 8447449 [details]
> prev_rmode_menu1.png
> 
> Use case:
> 
> I'm reading some stuff on my Android phone and I come across a link to an
> article. "This seems interesting" I think to myself. So, I tap this link and
> am presented with the following options in the list:
> 
> - Firefox
> - Some browser
> - Some other browser
> - Yet another app
> 
> I wonder if we provide a better user experience here and offer up the
> "Reader mode" as an option earlier on so the user will both know it exists,
> and can quickly get to the article via Reader mode instead of putting it one
> step further away.

This fits in with our ideas around better handling of external links (see bug 948509). We have thoughts of "Send to a device", "Open in background", "Open now" and now "Open in Reader".

> We might even go as far as saying our Reader mode is awesomest and even just
> launch the article/link in Reader mode every time.

Many of the resulting pages will not look good in Reader, so we need a fallback plan. Maybe have an option to use Reader whenever possible, else load as a normal webpage?
(In reply to Mark Finkle (:mfinkle) from comment #2)
> > We might even go as far as saying our Reader mode is awesomest and even just
> > launch the article/link in Reader mode every time.
> 
> Many of the resulting pages will not look good in Reader, so we need a
> fallback plan. Maybe have an option to use Reader whenever possible, else
> load as a normal webpage?

My mistake! I meant to say "every time (that there is a Reader mode option)" :P 

But, I think putting it in that list as a first step is probably the better option. Would be nice if we could test this out in a build or something to see how often this actually proves to be useful in the wild? Not sure if this would fulfill some of the questions/requirements of bug 1011712 either..
Flags: needinfo?(mark.finkle)
Just keep in mind that we have no idea if a give URL will display in Reader. And we really don't know until we start downloading the content. Currently, we wait until the document loads in a browser, then we run the code to test for Reader-capable. Timing will be the biggest hurdle in anything we do with opening an external URL to Reader.
Flags: needinfo?(mark.finkle)
(In reply to Mark Finkle (:mfinkle) from comment #4)
> Just keep in mind that we have no idea if a give URL will display in Reader.
> And we really don't know until we start downloading the content. Currently,
> we wait until the document loads in a browser, then we run the code to test
> for Reader-capable. Timing will be the biggest hurdle in anything we do with
> opening an external URL to Reader.

Right, I understand the technical limitations. I think this is definitely worth exploring though.
I was wondering if we might experiment with something similar to address discover-ability concerns (or even just general convenience) for our "Private browsing" mode.

Thoughts?
Flags: needinfo?(mark.finkle)
I think this bug/idea is now being handled by bug 1044947, right? We should just dupe this one over.
Status: NEW → RESOLVED
Closed: 10 years ago
Flags: needinfo?(mark.finkle)
Resolution: --- → DUPLICATE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: