Closed Bug 948509 Opened 6 years ago Closed 6 years ago

Share handler overlay: "Send to Firefox"

Categories

(Firefox for Android :: Overlays, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 35

People

(Reporter: rnewman, Assigned: ckitching)

References

(Depends on 1 open bug)

Details

(Keywords: meta)

Attachments

(2 files)

We currently have a Share handler for Firefox Sync, which sends a provided URL from anywhere in Android to a destination Sync device.

We don't have a way to:

* Open a link in Firefox (handier than you might think -- some apps only have Share, not View)
* Bookmark a link
* Add a link to my reading list
* Add a link to one of My Lists.

I think we should have an overlay that catches an inbound share, presents it briefly to the user, and allows them to send it via Sync (if set up), open it, or add it to one of their save destinations.

This is in the same vein as Springpad's approach:

https://dl.dropboxusercontent.com/u/3911373/Fennec/List/2.png
This is pretty closely aligned with how I've been thinking about this too. The design and interaction of the dialog needs to be thought through some more, but as Richard said, giving people the option to file away useful links for later retrieval in Firefox, or even open a link in Firefox to avoid some other app's poor quality web view, would be pretty awesome.
Yeah, this is definitely over to you now, Ian :D

We can do pretty much anything you can think of.
(In reply to Richard Newman [:rnewman] from comment #0)

> * Add a link to one of My Lists.

The way we've implemented "My Lists" aka home panels, this isn't really a thing to do. The closest thing would be if we let add-ons register to handle this, similar to what I'm proposing in bug 1014139.

However I think a share handler for Firefox is definitely something we should do. I wonder how much this overlaps with bug 788114
No longer blocks: lists
Yeah, that sentence is really talking about an overlapping feature with a similar name. Old bug! :D

Imagine calling it "Firefox Queue", or "My Pages", or something, or having an equivalent input into a Pocket panel or whatever. It would be a read-write equivalent to the current read-only Hub.


Re Bug 788114: my feeling is that this is a generalization of that bug, and also a generalization of Send Tab, as well as some ideas we've had around a kind of "soft open" of links from other apps.

Assuming that we won't build and ship that bug alone, gonna set a blocking relationship there.
Blocks: 788114
Yoink.
Assignee: nobody → chriskitching
Component: General → Overlays
I've been working on a prototype in this area.

A screencast of how share intents are handled at the moment can be seen here:
https://www.dropbox.com/s/km7ea71ix0ympn2/sharing.mp4

(imagine that the buttons you get after tapping have got appropriate icons on them, not Firefox logos. Also that the firefox logo on the main overlay is the favicon of the site (if we have it in the database)).

Work is continuing on the handling of VIEW intents with "link bubbles".

Any and all input is appreciated... Once people are happy with the UI interactions I'll get on with the stuff for integrating it with Fennec (and file a flurry of bugs in this component for continuing development)

While things remain a little undefined it seems sensible to keep the bugmail volume down :P

For now, this is under development as a separate app, the code for which can be found on BitBucket:
https://bitbucket.org/ckitching/bubblez

Those who wish to mash buttons excitedly (and perhaps experience the at present extremely broken handling of VIEW intents) can find an APK here:
https://www.dropbox.com/s/3avuwz6xtqcsf99/bubblez.apk
Got most of the kinks ironed out of the animation library now, so can present this slightly more sophisticated screencast:
https://www.dropbox.com/s/8qy8g7l1pw269rl/mergingBubblesForReal.mp4

Here, we see both the completed interaction for share intents, as well as some progresss towards the envisioned "link bubble" semantics for VIEW intents. 

Tapping a link will spawn a bubble.
The bubble should represent the site in some way, perhaps with its favicon. (though currently it's just a Firefox logo)

If tapped, the bubble flies to the bottom of the screen and presents the "select action" menu you get when you send a share intent, allowing you to do something with it right now.
If ignored for some duration (currently 3 seconds), the bubble merges with the peristent "master" bubble.
This "master" bubble is currently also represented by a firefox logo, confusingly, but eventually we might want it to in some way represent the number of pages that have previously merged with it.

Tapping this "master" bubble should open a list of all pages that have "merged" with the bubble in the recent past (for some value of "recent past"). This screen would allow you to do something with each of these pages ("open all in tabs", among other things?)


Sorry for the delay in getting this much of a demo: android's graphics system is quite obtuse! Having now abstracted the madness away it should be pretty straightforward to spin up arbitrarily many prototypes involving things whizzing around the screen (though note that any animation other than translation or fading in/out will prove quite challenging to achieve).

Thoughts? Any of this seem sane?
No longer blocks: 788114
Depends on: 788114
See Also: → 1044947
Depends on: 1040967
QA Contact: teodora.vermesan
> https://www.dropbox.com/s/3avuwz6xtqcsf99/bubblez.apk

Tested:
Device: Samsung Galaxy Nexus
OS: Android 4.2.
Build: Firefox for Android 34.0a1 (2014-08-04)
I've installed the apk provided. I've shared an article from news.google.com via BUBBLEZ and a notification appeared "Added to Firefox Reading List". But my reading list is empty.
When tapping the bubble which is present at the bottom of the screen, 4 Firefox logos appear:"Bookmark", "Add to reading list", "Send Tab", "Open". 
As you can see here: http://i.imgur.com/R3urpHJ.png, the font should be for example black. 
Tapping on "Bookmark" logo, a notification appears "Added bookmark in Firefox", but it is not added in the list. The same with the other 3 logos, nothing happens.
Also when tapping the bubble (to appear the 4 logos) if I press the home button, they won't dissappear: http://i.imgur.com/3Cm9Klh.png.
Depends on: 993885
Share overlay with refined visuals. I will attach assets and specs in a separate comment.

Previous work can be found: http://delivery.yuuuan.com/du9yadac
Change log for https://bugzilla.mozilla.org/show_bug.cgi?id=948509

1. Share panel: 
* Moved the Firefox logo to the top of the dialog, in order to avoid the confusion that the target link is from Firefox. 
* Refined icons: removed the rings around icon graphics to match with latest Android L design. Used Anthony's icon sets to keep the consistency

2. First-time tip for "Send tab to devices" on Mac and Windows
* Detect whether the paired device is Mac or Windows, show a screenshot that matches with the type of OS.
* Changed the layout of first-time tips. To keep consistency across: imagery on the left side, text on the right side.
* Added an orange highlight on "Sync" icon and applied the color to "Sync" text in the tips.

3.First-time tip for "Add to reading list"
* In the screenshot, change the indicator for unread items from a number to a dot. The number of unread items doesn't matter as much in this case. Also we've already have a number indicator for tabs, adding another one can be distracting.
Please find attached assets for the mockups above. Provided in MDPI, HDPI, XHDPI, and XXHDPI.
Some notes from me:

> 2. First-time tip for "Send tab to devices" on Mac and Windows
> * Detect whether the paired device is Mac or Windows, show a screenshot that
> matches with the type of OS.

This will require heuristics applied to the device name; we can't tell for sure anything more than "mobile" or "desktop".

We also should be prepared for other Android devices (not uncommon!), and also Linux.

(Chris, I'm happy to help with this.)

Finally, we should decide on a fallback for when we don't know the 'type' of another device -- we could guess Windows, we could skim the other devices on their account and use one of those, or we could do something else.


> * In the screenshot, change the indicator for unread items from a number to
> a dot. The number of unread items doesn't matter as much in this case. Also
> we've already have a number indicator for tabs, adding another one can be
> distracting.

I made a note in Bug 1044089.
Imma call this done after Bug 1092409 lands.
Status: NEW → ASSIGNED
Keywords: meta
Target Milestone: --- → Firefox 35
Depends on: 1092409
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 788114
You need to log in before you can comment on or make changes to this bug.