::first-letter pseudo elements show no border property

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
P2
normal
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Dylan Schiemann, Unassigned)

Tracking

(Blocks: 1 bug, {css1, regression, testcase})

Trunk
mozilla1.2beta
css1, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CSS1-2.4] (new bugs filled?))

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

16 years ago
Steps to reproduce:
1) Set border properties on first-letter pseudo element

Expected Bahvior:
1) Border around first-letter

Actual Behavior:
1) No Border is visible
This may be a regression.  Builds as recent as 0.9.2 would show a border for
first-letter pseudo elements, but 0.9.4 does not.  Testcase to follow
(Reporter)

Comment 1

16 years ago
Created attachment 52082 [details]
testcase: set first-letter pseudo element to have a 3px black border

Comment 2

16 years ago
guess this is a regression.
Keywords: regression
This sounds like it's more likely to be a layout problem than style system.

Comment 4

16 years ago
99% sure this regressed with the rule tree landing. It worked in the 05-31
build, but not in the 06-01 build. Reassign to hyatt and putting [RULETREE] in
summary
Assignee: dbaron → hyatt
Summary: first-letter pseudo elements show no border property → [RULETREE?] first-letter pseudo elements show no border property

Comment 5

16 years ago
Oh boy oh boy oh boy!
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.6

Updated

16 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7
Oh, there's code to do this intentionally in nsHTMLCSSStyleSheet.  It just has
to be removed in the right way.

Updated

16 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.2

Comment 7

16 years ago
What effect will this have on users of MachV?
Whiteboard: [CSS1-2.4]
Adding a "Dropped Initial" feature to Composer, I just discovered this bug too.
We don't draw borders on :first-letter.

IE and Opera don't have this bug. Konqueror has same bug.
Attachment #52082 - Attachment description: testcase: set first-letter pseudo element to have a 1px black border → testcase: set first-letter pseudo element to have a 3px black border
Created attachment 82512 [details] [diff] [review]
bring the :first-letter/:first-line rules in nsHTMLCSSStyleSheet mostly up to spec

This is a preliminary patch.
It might be a better solution if we did this work in nsRuleNode.cpp like we do
for :before and :after, though...
Created attachment 84214 [details] [diff] [review]
slightly better patch; still some problems

This one at least compiles and runs without assertions.
Taking the bug.  This really needs to be a post-resolve callback, though.
Assignee: hyatt → dbaron
Status: ASSIGNED → NEW
Priority: -- → P2
Target Milestone: mozilla1.2alpha → mozilla1.1beta
And while I think of it, this should be fixed for XML documents too...

Comment 14

15 years ago
Also observed using FizzillaCFM/2002061014. Marking All/All.
OS: Windows 2000 → All
Hardware: PC → All
Blocks: 153781

Updated

15 years ago
Blocks: 153699
Target Milestone: mozilla1.1beta → mozilla1.2alpha

Updated

15 years ago
Keywords: testcase

Updated

15 years ago
Keywords: css1
Whiteboard: [CSS1-2.4] → [CSS1-2.4][patch]
Target Milestone: mozilla1.2alpha → mozilla1.2beta
*** Bug 188654 has been marked as a duplicate of this bug. ***
Blocks: 191272
Doing it in the post resolve callback or in ApplyStyleFixups will break if
someone does something like 'margin: inherit' and gets the struct from the
parent, unless we go through a lot of work.  I think I'll just go with what I
have for now.
Created attachment 113147 [details] [diff] [review]
patch

Basically just updated.
Attachment #82512 - Attachment is obsolete: true
Attachment #84214 - Attachment is obsolete: true
Attachment #113147 - Flags: superreview?(bzbarsky)
Attachment #113147 - Flags: review?(bzbarsky)
Comment on attachment 113147 [details] [diff] [review]
patch

+  // Disable everything in the Display struct except 'float' and
+  // 'clear'.

This should be moved down to just before the code that actually does it, no?

With that, looks good...
Attachment #113147 - Flags: superreview?(bzbarsky)
Attachment #113147 - Flags: superreview+
Attachment #113147 - Flags: review?(bzbarsky)
Attachment #113147 - Flags: review+
Fix checked in to trunk, 2003-02-22 11:20 PST.  Still more work to be done here,
so leaving open, at least until I file a separate bug on the various issues
mentioned above.
Whiteboard: [CSS1-2.4][patch] → [CSS1-2.4]
Blocks: 83479

Updated

13 years ago
Summary: [RULETREE?] first-letter pseudo elements show no border property → ::first-letter pseudo elements show no border property
Whiteboard: [CSS1-2.4] → [CSS1-2.4] (new bugs filled?)

Comment 20

13 years ago
What about those new bugs?
Created attachment 166811 [details]
Testcase - margin:inherit

David, is this the case you mentioned in comment 16?

Updated

13 years ago
No longer blocks: 153781
Assignee: dbaron → nobody
QA Contact: ian → style-system

Comment 22

10 years ago
Is there still something left to be done here?

Comment 23

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

The bug as reported is fixed.
Attachment 166811 [details] (comment 21) should be a seperate bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.