border style not rendered on floating :first-letter pseudo-element

RESOLVED DUPLICATE of bug 103189

Status

()

--
trivial
RESOLVED DUPLICATE of bug 103189
16 years ago
16 years ago

People

(Reporter: cyril.pierron, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216

as described in section 2.4 of the CSS level 1 specification, the CSS border
properties should apply to the :first-letter pseudo element when its float
property is set (not defined as none). The test is very easy to reproduce on a
paragraph element using the following CSS rule :

p:first-letter {
	margin: 4px;
	border-width: thin;
	border-style: solid;
	border-color: black;
	padding: 4px;
	font-size: 28pt;
	float: left;
}

All the other properties are correctly handled but not the border ones.

Reproducible: Always

Steps to Reproduce:
1. create a simple html page containing a paragraph element P (enter some text
between the paragraph tags)
2. attach to this page the following CSS rule :

p:first-letter {
	margin: 4px;
	border-width: thin;
	border-style: solid;
	border-color: black;
	padding: 4px;
	font-size: 28pt;
	float: left;
}

3. display / render the html page (check the test.html page attached)
Actual Results:  
all the properties are correctly rendered (font-size, margin, padding) but not
the border ones. I've tried several border-style, several ways to set the border
(as with border: thin solid red;)

Expected Results:  
Following the CSS level 1 specification section 2.4 the border properties should
apply to a :first-letter pseudo elements when its float property is set to left
or right. In such a case the element is considered block-level. Ever if Mozilla
is one of my favorite browser, for once check the result under IE 6.0 SP1.
(Reporter)

Comment 1

16 years ago
Created attachment 111291 [details]
fault report test case

*** This bug has been marked as a duplicate of 103189 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.