If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add a_comment-end hook to show bug page

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
Attachments & Requests
--
minor
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Simon Green, Assigned: Simon Green)

Tracking

(Blocks: 1 bug)

Bugzilla 5.0
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Created attachment 8447781 [details] [diff] [review]
comment-v1.patch

This hook is used by Mozilla's Edit Comments extension, so it would be good to have it in the upstream code. All other eidt comment hooks already exist.
Attachment #8447781 - Flags: review?(gerv)
(Assignee)

Updated

3 years ago
No longer depends on: 1029354
Comment on attachment 8447781 [details] [diff] [review]
comment-v1.patch

Are you sure the current filename is the right second argument to the Hook.process() call? The docs:
http://www.bugzilla.org/docs/tip/en/html/api/Bugzilla/Hook.html
suggest the second argument is a hash of parameters.

Gerv
(Assignee)

Comment 2

3 years ago
(In reply to Gervase Markham [:gerv] from comment #1)
> Are you sure the current filename is the right second argument to the
> Hook.process() call? 

Yes.

> The docs:
> http://www.bugzilla.org/docs/tip/en/html/api/Bugzilla/Hook.html
> suggest the second argument is a hash of parameters.

The above documentation relates to code Hook. The hook in my patch is a template hook. The documentation of template hooks is at: http://www.bugzilla.org/docs/tip/en/html/api/Bugzilla/Template/Plugin/Hook.html
Comment on attachment 8447781 [details] [diff] [review]
comment-v1.patch

r=gerv.

Gerv
Attachment #8447781 - Flags: review?(gerv) → review+
Flags: approval?
(Assignee)

Comment 4

3 years ago
To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   171e504..70b1cb4  master -> master
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: approval? → approval+
Resolution: --- → FIXED
Duplicate of this bug: 980950
Blocks: 540
You need to log in before you can comment on or make changes to this bug.