Closed Bug 1032066 Opened 6 years ago Closed 6 years ago

[FxOS][V1.4][Dolphin] Default user of engineering build isn't "root"

Categories

(Release Engineering :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: whsu, Unassigned)

References

Details

(Whiteboard: [1.4-dolphin-test-run-1])

Product: Firefox OS
Device: Dolphin
Branch: V1.4
--- -- - --- -- - --- -- - --- -- - --- -- - --- -- - --- -- -
After flashing engineering build into Dolphin device, we found the user is not run as "root" and all test apps cannot be found on system.
Please help us address this problem because it has blocked the Gaia-UI-test.
Thanks.
Could someone help solve this problem?
This seriously impacted v1.4 Gaia UI test.
blocking-b2g: --- → 1.4?
Lets revisit this after bug 1027554 fixes the zip files used for flashing.
Depends on: 1027554
Component: Release Automation → General Automation
QA Contact: bhearsum → catlee
Not a release blocker.
blocking-b2g: 1.4? → ---
Bug 1027554 has given us 112MB dolphin.zip files for eng, vs 107MB for non-eng. They were both just a few KB before that fix, so I suspect no flashing happened when this was filed.

Please reopen if the eng build is incomplete in https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-b2g30_v1_4-dolphin-eng/20140707182829/or later. NB we haven't had any nightlies with the fix yet.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1027554
It is not a duplicate bug of bug 1027554.
After you resolved Bug 1027554, the problem is still happened.
We need to set the correct variable/configuration when we build Dolphin build.
Kai-Zhen may know the answer.
Thanks!

--- -- - --- -- - --- -- - --- -- -
Hi, Kai-Zhen,

Could I have your help?
Thanks!
Status: RESOLVED → REOPENED
Flags: needinfo?(kli)
Resolution: DUPLICATE → ---
William, I flashed today pvt eng build, it is running as root by default. 

$ adb shell
root@scx15_sp7715ga:/ # 

I also verified with my own build, it is also running as root by default.
My .userconfig is "VARIANT=userdebug".
Flags: needinfo?(kli)
William, Can you try again? If there is still the same error please call me.
(In reply to Kai-Zhen Li from comment #8)
> William, Can you try again? If there is still the same error please call me.

Hi, Kai-Zhen,

Yes, you got that right.
The image is running as root by default.
But, if I used partner's image(PAC file) then flash Gecko+Gaia on top of it, FxOS is running as normal user by default.
It caused by partner's images (PAC file)

Sorry for any inconvenience.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WONTFIX
Whiteboard: [1.4-dolphin-test-run-1]
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.