dolphin full image size is incorrect in pvt build

VERIFIED FIXED

Status

Release Engineering
General Automation
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Peipei Cheng (needinfo if you need my action), Assigned: nthomas)

Tracking

unspecified
Other
Other

Firefox Tracking Flags

(b2g-v1.4 fixed)

Details

Attachments

(1 attachment)

I found that the size for dolphin full image(dolphin.zip) is only 9.7K. Please help check. Thanks!

https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g30_v1_4-dolphin/2014/06/2014-06-19-00-02-01/

Comment 1

3 years ago
Hi, Chris,

Could I have your help?
The 1)"boot.img", 2)"system.img", 3)"recovery.img", and 4)"userdata.img" don't exist on the "b2g-distro" folder.
We seemed to forget to package the correct images.

Thanks!
Flags: needinfo?(catlee)
Looks like this is because the images are under 

out/target/product/scx15_sp7715ga/boot.img

In this case, the "zip_files" section of https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/file/1d5559029aac/b2g/config/dolphin/config.json needs to be updated to refer to the proper local directory.
Flags: needinfo?(catlee)

Comment 3

3 years ago
Could someone help on this problem?
Sometimes, we need these images to do automation test and manual test

Updated

3 years ago
blocking-b2g: --- → 1.4?
(Assignee)

Comment 4

3 years ago
Created attachment 8450602 [details] [diff] [review]
[mozilla-b2g30_v1_4]  Use real value of DEVICE when packaging

I've confirmed catlee's comment about the img files being in 
  {workdir}/out/target/product/scx15_sp7715ga/
and infer we should put them in 
  out/target/product/scx15_sp7715ga/
in the zip. This if from .config having |DEVICE=scx15_sp7715ga|, and $DEVICE being used in flash.sh. 

The line for {workdir}/boot.img is dropped because the file doesn't exist there, it's in {workdir}/out/target/product/scx15_sp7715ga/ so the glob catches it.
Assignee: nobody → nthomas
Status: NEW → ASSIGNED
Attachment #8450602 - Flags: review?(jlund)
(Assignee)

Updated

3 years ago
Blocks: 1032066

Comment 5

3 years ago
This won't block the release.
blocking-b2g: 1.4? → ---
Flags: needinfo?(nthomas)
(Assignee)

Comment 6

3 years ago
What is the needinfo asking for ? Current status is review pending.
Flags: needinfo?(nthomas) → needinfo?(itsay)

Comment 7

3 years ago
did it by accident.
Flags: needinfo?(itsay)
Comment on attachment 8450602 [details] [diff] [review]
[mozilla-b2g30_v1_4]  Use real value of DEVICE when packaging

logic seems sound. I could not track down a recent slave (all spots) to probe and confirm the locations of these.

I wonder if we need a verification (path.exists) check here: http://hg.mozilla.org/build/mozharness/file/08e9e0c0bc1b/scripts/b2g_build.py#l696

I guess it's hard since we don't know what to expect with a '*.img' glob
Attachment #8450602 - Flags: review?(jlund) → review+
(Assignee)

Comment 9

3 years ago
Maybe RyanVM can land this before I acquire a 1.4 tree.
Severity: normal → critical
Keywords: checkin-needed
(Assignee)

Comment 10

3 years ago
Clearing checkin-needed, I need to ask for approval before landing.
Severity: critical → normal
Keywords: checkin-needed
(Assignee)

Comment 11

3 years ago
Comment on attachment 8450602 [details] [diff] [review]
[mozilla-b2g30_v1_4]  Use real value of DEVICE when packaging

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Incomplete build setup in bug 1011129
User impact if declined: None
Testing completed: None
Risk to taking this patch (and alternatives if risky): None, affects pvtbuilds only
String or UUID changes made by this patch: None
Attachment #8450602 - Flags: approval-mozilla-b2g30?
I think this is quite critical. Without this fix, pvtbuilds for dolphin was built but nothing is packed into the update.zip. In other words, we spent machine hours to create build but build is not delivered correctly.
Comment on attachment 8450602 [details] [diff] [review]
[mozilla-b2g30_v1_4]  Use real value of DEVICE when packaging

b2g30+
Attachment #8450602 - Flags: approval-mozilla-b2g30? → approval-mozilla-b2g30+
(Assignee)

Comment 14

3 years ago
https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/98a7e09eb2bb
status-b2g-v1.4: --- → fixed
(Assignee)

Comment 15

3 years ago
Forced some dolphin builds on that rev for verification, but they won't show up at
  https://tbpl.mozilla.org/?tree=Mozilla-B2g30-v1.4&rev=98a7e09eb2bb
until they've finished (user error!).
(Assignee)

Comment 16

3 years ago
In the non-eng build:

16:04:08     INFO - Copy/paste: zip -r -9 -u /builds/slave/b2g_m-b30_14_dolphin_dep-00000/build/dolphin.zip b2g-distro
16:04:08     INFO -  	zip warning: /builds/slave/b2g_m-b30_14_dolphin_dep-00000/build/dolphin.zip not found or empty
16:04:08     INFO -    adding: b2g-distro/ (stored 0%)
16:04:08     INFO -    adding: b2g-distro/load-config.sh (deflated 41%)
16:04:08     INFO -    adding: b2g-distro/.config (deflated 19%)
16:04:08     INFO -    adding: b2g-distro/sources.xml (deflated 68%)
16:04:08     INFO -    adding: b2g-distro/out/ (stored 0%)
16:04:08     INFO -    adding: b2g-distro/out/target/ (stored 0%)
16:04:08     INFO -    adding: b2g-distro/out/target/product/ (stored 0%)
16:04:08     INFO -    adding: b2g-distro/out/target/product/scx15_sp7715ga/ (stored 0%)
16:04:08     INFO -    adding: b2g-distro/out/target/product/scx15_sp7715ga/ramdisk.img (deflated 0%)
16:04:09     INFO -    adding: b2g-distro/out/target/product/scx15_sp7715ga/recovery.img (deflated 47%)
16:04:11     INFO -    adding: b2g-distro/out/target/product/scx15_sp7715ga/boot.img (deflated 50%)
16:04:11     INFO -    adding: b2g-distro/out/target/product/scx15_sp7715ga/userdata.img (deflated 100%)
16:04:16     INFO -    adding: b2g-distro/out/target/product/scx15_sp7715ga/system.img (deflated 14%)
16:04:16     INFO -    adding: b2g-distro/out/target/product/scx15_sp7715ga/cache.img (deflated 100%)
16:04:16     INFO -    adding: b2g-distro/out/target/product/scx15_sp7715ga/ramdisk-recovery.img (deflated 0%)
16:04:16     INFO -    adding: b2g-distro/flash.sh (deflated 61%)
16:04:16     INFO - Return code: 0

dolphin.zip is 107MB. We get 112MB of dolphin.zip for the eng build.

pcheng, you could verify with https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-b2g30_v1_4-dolphin/20140707182704/ (or later).
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1032066

Comment 18

3 years ago
Cool! Thanks everyone! Dolphin build is back.
I have successfully flashed these images into dolphin devices.
But, the ENG build still doesn't have test apps, it may relate to build configuration.
I would like to trace it on the other bug.

I am grateful for your help.
Thanks! Have a nice day!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.