Grey bar remains on the bottom of the screen after exiting full screen mode

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
P5
normal
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: CristinaM, Unassigned, Mentored)

Tracking

(Blocks: 1 bug, {regression, testcase})

Trunk
ARM
Android
regression, testcase
Points:
---

Firefox Tracking Flags

(firefox34 affected, firefox35 affected, firefox36 affected, firefox37 affected, firefox38 affected, firefox39 affected, firefox40 affected, firefox41 affected, fennec+)

Details

(Whiteboard: [lang=java][lang=js], URL)

(Reporter)

Description

4 years ago
Environment:
Device: Nexus 4 Android (4.4.2)
Build: Firefox for Android 33.0a2 (2014-06-30)

Steps to reproduce:
1. Launch Fennec and go to www.cd.pn/b2/;
2. Tap on Full screen button;
3. Disable full screen by tapping on the Exit full screen icon.

Expected result:
The video exists full screen correctly.

Actual results:
A grey part is displayed in the bottom of the screen.
After scroll, the url bar is grey for a few seconds and then the page is resized.

Notes: See video
https://www.youtube.com/watch?v=FkV8Z59kTxU&feature=youtu.be
Might be a dupe of bug 998929. Please work on a regression range.
tracking-fennec: --- → ?
Flags: needinfo?(cristina.madaras)
Keywords: regressionwindow-wanted
Summary: Grey parts when disabling full screen video → Grey bar remains on the bottom of the screen after exiting full screen mode

Updated

4 years ago
Flags: needinfo?(cristina.madaras)
Keywords: regression
QA Contact: cristina.madaras
(Reporter)

Comment 2

4 years ago
Regression window:
Last good revision: 611698b4a246 (2014-01-27)
First bad revision: 4da3e21a0e5f (2014-01-28)

Pushlog: http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=611698b4a246&tochange=4da3e21a0e5f
Keywords: regressionwindow-wanted
I too think this is a dupe of bug 998929 or wherein pretty much the same problem.

It's too reproducible using https://developer.mozilla.org/samples/domref/fullscreen.html. After exiting full-screen, the toolbar completely disappears and the page is bumped up and the underlying canvas is shown behind the page as a different background colour.

Kats, do you think this is the same problem as bug 998929?
Component: General → Graphics, Panning and Zooming
Flags: needinfo?(bugmail.mozilla)
Keywords: testcase
If the range in comment 2 is right then it's likely not the same problem as bug 998929 but I can't say for sure without investigating. Also there's nothing in the range in comment 2 that would explain this behaviour.
Flags: needinfo?(bugmail.mozilla)
(In reply to cristina.madaras from comment #2)
> Regression window:
> Last good revision: 611698b4a246 (2014-01-27)
> First bad revision: 4da3e21a0e5f (2014-01-28)
> 
> Pushlog:
> http://hg.mozilla.org/integration/fx-team/
> pushloghtml?fromchange=611698b4a246&tochange=4da3e21a0e5f

Are you sure this is an fx-team branch regression?
(Reporter)

Comment 6

4 years ago
Is not an fx-team branch regression. I verified this again and the pushlog is: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=611698b4a246&tochange=4da3e21a0e5f
Sorry about that!
(Reporter)

Comment 7

4 years ago
(In reply to cristina.madaras from comment #6)
> Is not an fx-team branch regression. I verified this again and the pushlog
> is:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=611698b4a246&tochange=4da3e21a0e5f
> Sorry about that!

Seems that I had some problems with Mozregression, it didn't work properly and gave me some errors. After reinstall I investigated again this bug and this is what I found:

1.
Build from 2013-03-07 ee4879719f78 - video looks good in both normal and full screen mode.
Build from 2013-03-08 cb432984d5ce - when entering in full screen mode the canvas is displayed at the top of the screen, going back at the normal screen looks good.

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ee4879719f78&tochange=cb432984d5ce

2.
Build from 2013-07-11 dde4dcd6fa46 - in full screen mode the canvas is still displayed at the top of the screen.
Build from 2013-07-12 b44898282f21 - in full screen mode the video looks good, going back at normal screen, sometimes the top of the page gets cut-off as if the page is underneath the title bar, sometimes the canvas is displayed at the bottom of the screen and the toolbar disappears.

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dde4dcd6fa46&tochange=b44898282f21
Kats, can you look at those pushlogs?
(In reply to cristina.madaras from comment #7)
> (In reply to cristina.madaras from comment #6)
> 1.
> Build from 2013-03-07 ee4879719f78 - video looks good in both normal and
> full screen mode.
> Build from 2013-03-08 cb432984d5ce - when entering in full screen mode the
> canvas is displayed at the top of the screen, going back at the normal
> screen looks good.
> 
> Pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=ee4879719f78&tochange=cb432984d5ce

Likely bug 716403.

> 2.
> Build from 2013-07-11 dde4dcd6fa46 - in full screen mode the canvas is still
> displayed at the top of the screen.
> Build from 2013-07-12 b44898282f21 - in full screen mode the video looks
> good, going back at normal screen, sometimes the top of the page gets
> cut-off as if the page is underneath the title bar, sometimes the canvas is
> displayed at the bottom of the screen and the toolbar disappears.
> 
> Pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=dde4dcd6fa46&tochange=b44898282f21

Likely bug 853986. Maybe bug 877602 but I doubt it.
Assignee: nobody → bugmail.mozilla
tracking-fennec: ? → +
I won't be getting around to this anytime soon. Wes might be a better person to look at it.
filter on [mass-p5]
Priority: -- → P5
Assignee: bugmail.mozilla → nobody

Updated

3 years ago
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected
status-firefox37: --- → affected
(Reporter)

Updated

3 years ago
status-firefox38: --- → affected
Mentor: wjohnston@mozilla.com, margaret.leibovic@gmail.com
Whiteboard: [lang=java][lang=js]
Duplicate of this bug: 1135780
(from bug 1135780) I can only repro on my galaxy chat with dynamic toolbar enabled.

Updated

3 years ago
status-firefox39: --- → affected

Updated

3 years ago
status-firefox40: --- → affected

Updated

3 years ago
status-firefox41: --- → affected
qawanted to retest on the latest nightly. I think it might be fixed with bug 1180295 and bug 1197233 but in my local testing I think I saw it once still, so I'd like to get a second opinion.
Keywords: qawanted
Works for me in nightly and can reproduce on Firefox 40. I do have a followup that the video is restored underneath the address bar after exiting full screen.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Filed bug 1198530 for those of you following along at home.
You need to log in before you can comment on or make changes to this bug.